1

While running hp-setup from the hplip package, a dialog asks me to enter root/superuser password in order to install a downloaded plugin. Is that ok and part of the overall procedure? As I understand it, hplip is userspace...

  • Yes, provided that script hasn't been tampered with and the source is authentic! – George Udosen Sep 30 '18 at 17:55
  • Thanks, George. So I made sure it is authentic by tracking down the source of hp-setup, which is a symlink in the hplip package, pointing to a script setup.py from hplip-data - downloaded the deb package manually, looked into the md5sums file from control, checked it against md5sum of setup.py on my system /usr/share/hplip/setup.py and they match. All good. – isync Oct 1 '18 at 12:26
  • Then you good to go! – George Udosen Oct 1 '18 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.