0

Background

I have a Panasonic FZ-G1 MkIII Toughpad touchscreen tablet PC which is based on an x86-64bit Intel® Core™ i5-5300U CPU @ 2.30GHz, with 4Gb RAM.

This is dual-booted with Windows 10 Pro 64bit (build 1803) and Ubuntu 18.04.1 LTS 64bit.

The mobile sim is a standard giffgaff sim which works fine in Windows on this machine - it is recognised and internet access via it works, detected as LTE (4G). So this proves that the sim is working correctly with the WLAN modem hardware in this tablet.

However, when the same tablet is booted into Ubuntu 18.04.1 LTS 64bit, the same sim that worked in the Windows partition, does not work in Ubuntu. Error message: "Connection Failed: Activation of network connection failed" pops up when attempting connection via Settings. The IMEI is recognised and shown by the Settings. I tried with and without the default PIN 5555 (ref: https://community.giffgaff.com/t5/Help-Support/default-SIM-PIN/td-p/10007119 )

Following advice elsewhere from searching, it would appear that the chipset hardware for the WLAN mobile broadband modem in this tablet is of the make Sierra Wireless (see output of commands below).

The question

How could I get Ubuntu 18.04.1 to work with this giffgaff sim in this WLAN modem hardware, please? Do I need to install different drivers or adjust configuration files or both?

Command line output:

robdavishome@FZ-G1-Ubuntu:~$ mmcli -m 0 

/org/freedesktop/ModemManager1/Modem/0 (device id 'df18453f01d7e92f51f80c09fa46982ba404aa31')
  -------------------------
  Hardware |   manufacturer: 'Sierra'
           |          model: 'MBIM [1199:9041]'
           |       revision: 'SWI9X15C_05.05'
           |      supported: 'gsm-umts, lte'
           |        current: 'gsm-umts, lte'
           |   equipment id: '354078070723885'
  -------------------------
  System   |         device: '/sys/devices/pci0000:00/0000:00:14.0/usb2/2-7'
           |        drivers: 'cdc_mbim'
           |         plugin: 'Sierra'
           |   primary port: 'cdc-wdm3'
           |          ports: 'wwp0s20u7c2i12 (net), cdc-wdm3 (mbim)'
  -------------------------
  Numbers  |           own : 'unknown'
  -------------------------
  Status   |           lock: 'none'
           | unlock retries: 'sim-pin2 (3)'
           |          state: 'registered'
           |    power state: 'on'
           |    access tech: 'lte'
           | signal quality: '77' (cached)
  -------------------------
  Modes    |      supported: 'allowed: 2g, 3g, 4g; preferred: none'
           |        current: 'allowed: 2g, 3g, 4g; preferred: none'
  -------------------------
  Bands    |      supported: 'unknown'
           |        current: 'unknown'
  -------------------------
  IP       |      supported: 'ipv4, ipv6, ipv4v6'
  -------------------------
  3GPP     |           imei: '354078070723885'
           |  enabled locks: 'fixed-dialing'
           |    operator id: '23410'
           |  operator name: 'giffgaff'
           |   subscription: 'unknown'
           |   registration: 'home'
  -------------------------
  SIM      |           path: '/org/freedesktop/ModemManager1/SIM/0'

  -------------------------
  Bearers  |          paths: '/org/freedesktop/ModemManager1/Bearer/0'

robdavishome@FZ-G1-Ubuntu:~$ mmcli -L

Found 1 modems:
    /org/freedesktop/ModemManager1/Modem/0 [Sierra] MBIM [1199:9041]

robdavishome@FZ-G1-Ubuntu:~$ 

Annotated Research I did before asking this question

GiffGaff are a MVNO that use the O2 network in the UK, owned by Telefonica. GiffGaff's parent company is O2 (at time of writing) (Ref).

Thanks for reading. Please let me know if you can advise on my question.

0

I had loads of trouble trying to get my O2 sim to connect on Xubuntu 18.04 LTS.

What ended up fixing it was removing the Number Field so it was blank '' and setting the Authentication Methods under the PPP tab to 'PAP' only.

This will differ for you as you're on Giff Gaff. But on O2 I had the username as 'o2web', password as 'password' and the APN as 'wap.o2.co.uk'.

  • Thank you. I will try this. I had a thought just now that perhaps the number field was the full phone number for the sim - I hadn't tried that, so I will try your suggestions and also with the number field populated. – therobyouknow Jan 10 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.