2

I can execute the file via terminal. But how can I tell Nautilus to do the same on double click?

error on double-click

nautilus file permissions

1

You can add mime type associations in $/.local/share/application/mimeapps.list for current user. Sample snippet is here,

    [Added Associations]
    application/excel=planmaker-free18.desktop;
    application/mspowerpoint=presentations-free18.desktop;
    application/msword=textmaker-free18.desktop;
    application/ppt=presentations-free18.desktop;

   [Default Applications]
   text/html=google-chrome.desktop
   text/x-arduino=arduino-arduinoide.desktop

You have to first add new association it to [Added Associations] section and then add to [Default Applications] section to make default. For your type in question add application/x-sharedlib=some-application.desktop in both sections. Then save the file and try to open. May be you want to restart the nautilus.

If you want to make edits globally edit file in /usr/share/application/default.list

  • I'm aware of mimeapps.list. But it won't work for an executable – lamino Sep 30 '18 at 6:55
  • with which application do you need to open that file? – ultimatex Sep 30 '18 at 6:59
  • In terminal I would use ./. But bash is unable to run it. So I don't think any application is capable of running it – lamino Sep 30 '18 at 7:03
  • Yes,Shared libraries cannot directly execute via terminal or any other application. I answered above question as general file type association . – ultimatex Sep 30 '18 at 7:06
  • Alright. So what I was missing was the -c option for bash in the .desktop file. Thanks! – lamino Sep 30 '18 at 7:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.