2

Please don't flag this question as a duplicate because I really need your help. I once used OpenDNS in my router to block some websites & now I'm stuck with at whatever I do. I have already removed OpenDNS from my router & tried half of the commands suggested in other question but none of them work for me. Most of the websites which deal with a proxy, adult content etc. are all blocked & I'm requesting for a solution.

6

This should clear it

# sudo systemd-resolve --flush-cache

You can check with

# sudo systemd-resolve --statistics
  • it should show 0 in Current cache size

    DNSSEC supported by current servers: no
    Transactions
    Current Transactions: 0
    Total Transactions: 93750
    
    Cache
      Current Cache Size: 0
      Cache Hits: 18686
    Cache Misses: 28576
    
    DNSSEC Verdicts
          Secure: 0
        Insecure: 0
           Bogus: 0
    Indeterminate: 0
    
  • My current cache is still not 0 – Goutam Hebbar Nov 21 '18 at 15:43
  • You need to get into the ROUTER settings and flush the cache there as that's where your DNS lookups entries are cached, not on your local computer. If you need help with that, you might want to visit a forum that focuses on your router model. – Compatico Jan 23 at 0:16
  • @Michael what version of Linux are you using ? – Morgan Cox Feb 5 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.