2

I'm trying to install Ubuntu 18.04 on my ASUS F556U laptop without success. I already asked other questions on the subject, thinking that the problems were by UEFI mode. Well surpassed that, I already discovered that the problem is of the laptop, a professional I assure to me that it can be problem of Targeta Grafica, is not compatible with Linux. Well, since I can not install 18.04 install 16.04 but when updating it is broken and there is an error in the screen that I can not distinguish well, which I show: PCIe Bus Error: severity = Corrected, type = Physical Layer, id

When installing 16.04 it works perfectly, but it notifies me of an internal error, to send to Ubuntu. The error I show you in a screenshot. I hope someone can help me, maybe there is already a question on the subject on this site, but maybe I did not know how to look for it. I've been with the problem for almost two months, and now I can not buy another laptop, if it does not work for Linux. I already tried other Linux distributions, and it gives me the same error. Now it gives me another problem, a message saying that I have little space in the root file system, only 924 MB, when I leave 150 GB. If you can give me an idea, thank you. I show you screenshots of the errors you asked me to send to Ubuntu

EDITO: *

The partner @oldfred helped me with his comments, but ASUS does not give me support for UBUNTU, to be able to update the BIOS. I do not know if I am adding PCI = NOMSI correctly, because when I update, the error of the first image that I am attaching is shown on the screen. If you could help me, it is very frustrating to have a laptop with which I must work and not be able to install Ubuntu. Well, I think the reality is that Ubuntu is not installed, because Asus is giving me a lot of war.

* enter image description here

enter image description here enter image description here

enter image description here

enter image description here

  • 1
    Does boot parameter help? Problems Installing on ASUS F555U needed boot option pci=nomsi ubuntuforums.org/showthread.php?t=2303665 Asus x555u w/o pci=nomsi - space issue on drive and runaway log files filling drive ubuntuforums.org/showthread.php?t=2327103&page=3 & ubuntuforums.org/showthread.php?t=2327570 – oldfred Sep 29 '18 at 17:13
  • 1
    If you can boot you can add it to sudo nano -B /etc/default/grub Or if you can boot to recovery mode, you can also add it. If not you have to use live installer, mount install & edit from there. You can use it one time (or each time you reboot) from grub menu like nomodeset. At grub menu you can use e for edit, scroll to linux line and replace quiet splash with nomodeset. Some of the links above show more details. – oldfred Sep 29 '18 at 19:10
  • 1
    Is that from live installer or your actual install? If path not correct will be an empty file. But copy & paste above command works on my system. – oldfred Sep 30 '18 at 1:41
  • 1
    Have you updated UEFI from Asus for your system? – oldfred Sep 30 '18 at 14:50
  • 1
    I used google to find Asus site, went to support page & your model. Found these general instructions for Asus: icr-am.asus.com/webchat/…, but you have to go to the Asus support page for your model and see if version of UEFI/BIOS is newer. – oldfred Sep 30 '18 at 15:28
4
+100

Almost all systems need to have UEFI/BIOS updated to latest available from vendor. So first thing to check is if UEFI/BIOS is latest version from vendor. Normally there is only one version and it may say Windows. But Microsoft requires vendors to allow users to turn off UEFI Secure Boot. But even if UEFI Secure boot is on, Ubuntu should install. But proprietary drivers may require you to turn off Secure Boot.

Many Asus models need a boot parameter pci=nomsi. On initial boot you can manually add it to grub menu. But if a parameter is always required you will want to make it permanent by editing this and then updating grub.

https://wiki.ubuntu.com/Kernel/KernelBootParameters

sudo nano /etc/default/grub
sudo update-grub

Change this in /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"

Similar systems with issue: ASUS X540U pci=noaer instead of pci=nomsi and it also worked

https://ubuntuforums.org/showthread.php?t=2391201

Problems Installing on ASUS F555U needed boot option pci=nomsi

http://ubuntuforums.org/showthread.php?t=2303665

Asus x555u w/o pci=nomsi - space issue on drive and runaway log files filling drive

https://ubuntuforums.org/showthread.php?t=2327103&page=3

https://ubuntuforums.org/showthread.php?t=2327570

  • Hello @oldfred, Use pci = nomsi to start the installation and it worked, already with 18.04 installed and without giving errors, I would like to leave it permanently and I do not know how to edit that file: / etc / default / grub that now I can not access, what words should I add GRUB_CMDLINE_LINUX_DEFAULT = "quiet splash" in the file? Could you show me a capture of how it is once edited? Thank you. – Miguel Espeso Oct 6 '18 at 16:31
  • 1
    See update for before & after on line you need to edit. – oldfred Oct 6 '18 at 18:04
  • I do not understand your answer... @oldfred . I'm running 18.04 without problems – Miguel Espeso Oct 6 '18 at 18:56
  • 1
    Did you update /etc/default/grub by adding pci=nomsi after "quiet splash"? Otherwise you have to manually add it each time you reboot to linux line in grub menu. – oldfred Oct 6 '18 at 20:59
  • Thank you, I would not have achieved it without you. – Miguel Espeso Oct 6 '18 at 21:55
1

I see your BIOS is old version X556UJ.206. Pretty sure there are newest versions. I have seen American Megatrends Inc. X556UJ.302 (12/09/2015)

You need to update it first.

First download this tool to identify your mb and the BIOS:

https://ami.com/en/download-license-agreement/?DownloadFile=Motherboard_ID_Tool.zip

Most likely you you need to get the latest AMIBIOS from here:

https://ami.com/en/download-license-agreement/?DownloadFile=AMIBIOS8_AMI_Firmware_Update_Utility.zip

Run it and update the BIOS.

Then try installation again.

If you have any issues contact AMI BIOS support directly you don't need ASUS guys:

https://ami.com/en/support/technical-support/

  • Thanks @Wolfie, I could solve with the answer that is above. I have reviewed your answer and could have also served. That answer is already accepted. The guys from Asus help you and give solutions for Windows, to which I had to resort to solve. – Miguel Espeso Oct 7 '18 at 15:41
0

I'm running Ubuntu 18.04 on the same notebook.

Premise: touchpad is not working and also on shut down you have to press the power button to turn off the computer; I searched just a while for an easy fix but did not find. My notebook worked great with Ubuntu 14 and 16, I updated only because I need systemd for development reason, but if you going to use as a regular notebook, I suggest to install version 16 - it also has problem with acpi but at least everything works.

Anyway, to install it I built an usb stick with the iso with dd

dd if=/path/to/iso of=/dev/sdc 

NB check the correct device for your usb stick

Then boot from usb without any UEFI options, no way (at least for me) to do usign UEFI.

I don't remember exactly the options to set on installation about acpi - it was about 6 months ago - but this is my entry on grub so I guess there are the same

linux   /boot/vmlinuz-4.15.0-36-generic root=UUID=8fb6..81 ro priority=low acpi=off noapic quiet splash $vt_handoff
  • Thanks for your input @Simone Sanfratello, but it does not help me much. I also need it for development, and if I do not use UEFI, you can not install Ubuntu. – Miguel Espeso Oct 4 '18 at 20:26
  • 1
    Hello @Simone Sanfratello, following the instructions of the links that gave me oldfred, you will have an installation of 18.04 working perfectly, touch panel, normal shutdown, etc. The most important thing was to update BIOS, which I could do installing windows, with Ubuntu I did not get it, although there are ways to do it. – Miguel Espeso Oct 6 '18 at 12:10
  • Hello @Simonesanfratello, when I installed in the way indicated above, everything worked perfectly. But now it is failing something: sometimes I must turn off the button. Can I solve this problem? If I will ask a new question to try to solve it. Thank you. – Miguel Espeso Oct 31 '18 at 11:13

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.