0

I'd like to test kazam (the screencast program) so I try to launch it from the source code.

In the kazam directory, I've done:

python app.py` 

but except some warning about gtk, nothing happens. Is it possible?

app.py:24: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses
  import imp
app.py:33: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, Gdk, GObject
/home/campagne/Documents/unstable/kazam/backend/webcam.py:24: PyGIWarning: GUdev was imported without specifying a version first. Use gi.require_version('GUdev', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import GObject, GUdev
/home/campagne/Documents/unstable/kazam/backend/gstreamer.py:35: PyGIWarning: Gst was imported without specifying a version first. Use gi.require_version('Gst', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import GObject, Gst, GstVideo
/home/campagne/Documents/unstable/kazam/backend/gstreamer.py:35: PyGIWarning: GstVideo was imported without specifying a version first. Use gi.require_version('GstVideo', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import GObject, Gst, GstVideo
/home/campagne/Documents/unstable/kazam/frontend/window_area.py:29: PyGIWarning: Wnck was imported without specifying a version first. Use gi.require_version('Wnck', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, GObject, Gdk, Wnck, GdkX11
/home/campagne/Documents/unstable/kazam/frontend/window_countdown.py:29: PyGIWarning: PangoCairo was imported without specifying a version first. Use gi.require_version('PangoCairo', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, GObject, GLib, Gdk, Pango, PangoCairo

EDIT: Not a complete solution but at least it's not messing with my installation.

I'm using pip. In a virtual environment, I can do :

pip install -e unstable

and it will install it. (unstable is the repo folder where setup.py must be inside) Each code fix, I can do:

pip install --upgrade -e unstable

Not bad!

0

I can recommend to install Kazam from repositories (available since 14.04 LTS as version 1.4.4) with all dependencies by the commands below:

sudo add-apt-repository universe
sudo apt-get install kazam

and then test it.

If its functionality is not enough, then try to use your source-based version. It will start normally as all dependencies were installed.

  • I need the last version (1.5.4) and I need to make some modifications inside the source code (I'll try to solve some bugs). That's why I'd prefer to launch it directly without installing/uninstalling after each code fix. – ThePhi Sep 29 '18 at 14:27
  • The method above will install the dependencies. Do you really want to install all them by hand? You can continue to use source-based version instead of /usr/bin/kazam. But it will not start with missed dependencies. – N0rbert Sep 29 '18 at 14:29
  • I've already installed kazam (and it works normally) from the repo (v1.4.5). So I guess it's not a missing dependencies – ThePhi Sep 29 '18 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.