1

I would like a black, empty margin surrounding my entire screen, effectively turning a 24" monitor into a 20" one instead.

My setup:

  • Ubuntu 18.04.1 LTS
  • Intel Graphics
  • Xfce4 (I'd prefer a cross desktop enviroment solution)

Having tried xrandr with a combination of many different parameters, including: --scale, --panning, etc. I cannot shrink my monitor as desired.

If shrinking my monitor isn't possible with xrandr, fbset or some other tool, does an option to add in my /usr/share/X11/xorg.conf.d/20-intel.conf file exist?

  • What happens when you run xrandr with the --scale option? Did you specify which output, did it display an error? – Kristopher Ives Sep 29 '18 at 1:41
  • Possible duplicate of Can I zoom out windows or scale the whole desktop? – Kristopher Ives Sep 29 '18 at 1:41
  • 1
    --scale 2x2 doubles the screen resolution, --scale 0.5x0.5 does nothing. – charlie Sep 29 '18 at 1:45
  • What about xrandr -s 100x100 or similar? – Kristopher Ives Sep 29 '18 at 1:47
  • I have seen that thread many times, but nothing there works. – charlie Sep 29 '18 at 1:47
1

...effectively turning a 24" monitor into a 20" one...

That is surprisingly easy to achieve (replace DVI-0 with your monitor, of course):

xrandr --output DVI-0 --set "underscan hborder" 128 --set "underscan vborder" 128

...and turn it on/off using:

xrandr --output DVI-0 --set underscan on
xrandr --output DVI-0 --set underscan off

On a 24" monitor, the image should shrink down to about 20.2".

The borders have to be values in the range 0-128, where 1 results in the smallest borders, 128 in the largest, and 0 is somewhere in between. I don't know what these values actually represent.

| improve this answer | |
  • 1
    charlie:~$ xrandr --output HDMI1 --set "underscan hborder" 128 --set "underscan vborder" 128 X Error of failed request: BadName (named color or font does not exist) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 11 (RRQueryOutputProperty) Serial number of failed request: 43 Current serial number in output stream: 43 – charlie Sep 29 '18 at 15:27
  • 1
    Please look at the output of xrandr --verbose, maybe your monitor doesn't support underscan, but I tested it with a really old monitor, so I doubt it. Try enabling underscan first, before setting the borders. It may be helpful to add the output of xrandr --verbose to your question. – danzel Sep 29 '18 at 15:32
0

I don't see why you would want to do this, it might even cause burn-in problems depending on your monitor, but instead of changing the display (xrandr) resolution/display/pixels, try this:

  • Make some new XFCE panels on the top, sides, and bottom, with a solid black colour (in the Appearance tab) and options like this in the Display tab (changing the Row Size to however thick you prefer):

    enter image description here

    Maximized windows will not cover the panels, and you could even use one side as an extra-large status / window panel (if your desktop is like that, similar to XFCE's defaults). I'm pretty sure every desktop has some sort of panels that should work similarly.

| improve this answer | |
  • This wouldn't trap the mouse within the desired area, nor alter full screen windows such as YouTube. – charlie Sep 29 '18 at 3:30
  • XFCE's Settings -> Workspaces -> Margins tab stops maximized windows (similar to the panels), but not full-screen browsers and probably not youtube either... strange that it doesn't – Xen2050 Sep 29 '18 at 3:52
  • Yeah, those margin settings are for normal computer usage (I'm happy with a full display for that), I just find full screen videos too big when I'm tired. – charlie Sep 29 '18 at 4:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.