So I've been experimenting with Ubuntu on and off for a while, but I honestly have no idea what the hell I'm doing. So I have a realtek RTL8812bu WiFi dongle that I'm hoping to get working. I did some research, and came across this driver on GitHub that a couple people across two threads said worked for them:

At the bottom it said there is a new version here. So somewhere it said it was confirmed to work on kernels up to 4.16, so I checked and I'm on 4.15.0. But the problem I'm having, is what am I supposed to do? There is some installation guide at the bottom that is about as clear as mud to me since I don't know much.

  • Welcome to Ask Ubuntu! What version of Ubuntu are you using? Sep 29, 2018 at 1:12

3 Answers 3


Almost all of the instructions are in the README on the second site you linked. I’ll fill in a few blanks.

With a working internet connection by ethernet, tethering or whatever means possible, open a terminal and do:

sudo apt-get update
sudo apt-get install build-essential dkms git
git clone https://github.com/cilynx/rtl88x2BU_WiFi_linux_v5.2.4.4_26334.20180126_COEX20171012-5044.git

Now, from the README:

cd rtl88x2BU_WiFi_linux_v5.2.4.4_25643.20171212_COEX20171012-5044
VER=$(cat ./version)
sudo rsync -rvhP ./ /usr/src/rtl88x2bu-${VER}
sudo dkms add -m rtl88x2bu -v ${VER}
sudo dkms build -m rtl88x2bu -v ${VER}
sudo dkms install -m rtl88x2bu -v ${VER}
sudo modprobe 88x2bu

Please be aware that the ‘build’ process takes a few moments; please be patient.

Your wireless should now be working.

  • This one is for Kernel 5.3 but my installation either, thru dkms and sudo make install, both fails. github.com/cilynx/… Nov 27, 2019 at 20:29
  • 1
    @InfiniteLoops Please start a new question and we'll be glad to help.
    – chili555
    Nov 27, 2019 at 20:35
  • will do, later. Nov 27, 2019 at 22:05
  • 2
    Works with new firmware version rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959 in Linux Mint 19.3
    – lordneru
    Jan 2, 2020 at 16:33
  • 1
    Confirmed it works on Ubuntu 16.04 for some cheap chinese card descibed as AC1200 dual band 5GHz 2.4GHz USB3.0 802.11AC RTL8812BU. Minor corrections were needed. Current repository is: github.com/cilynx/… and first two lines from README now are cd rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959 and VER=$(sed -n 's/\PACKAGE_VERSION="\(.*\)"/\1/p' dkms.conf) (as also seen in DKMS installation section on GitHub page) Mar 14, 2020 at 20:23

I tried several different drivers, but the one I finally got it working was from this repo: https://github.com/morrownr/88x2bu

In short, the steps you should take are:

  1. Test that your dongle actually needs RTL8812BU drivers:

    • In a terminal (Ctrl+Alt+T) run:


      This will give you something like:

      Bus 001 Device 002: ID 2357:0115
    • Google the ID number, e.g. "wiki 2357:0115", and you will find out which Realtek driver you need.

  2. If you indeed need RTL8812BU and you are on Ubuntu 18.04, 20.04, or 20.10, run the following:

    sudo apt-get update
    sudo apt-get install -y dkms git
    mkdir src
    cd src
    git clone https://github.com/morrownr/88x2bu.git
    cd 88x2bu
    sudo ./install-driver.sh
    sudo reboot
  • Best answer in 2021. Note that you don't need to reboot. Do modprobe 88x2bu and the module will be loaded.
    – Déjà vu
    Aug 16, 2021 at 16:30
  • Confirmed, still working on Linux 5.11.0-37-generic #41~20.04.2-Ubuntu SMP Fri Sep 24 09:06:38 UTC 2021 - Thank you. Oct 7, 2021 at 16:00
  • 2
    I was able to get the Asus USB AC53 nano working on ubuntu 22.04 with the above instructions. Only difference was git clone https://github.com/morrownr/88x2bu-20210702
    – venvar
    Apr 27, 2022 at 4:29

You could try the next:

sudo apt-get update
sudo apt-get install build-essential dkms git
git clone https://github.com/cilynx/rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959
cd rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959
VER=$(sed -n 's/\PACKAGE_VERSION="\(.*\)"/\1/p' dkms.conf)
sudo rsync -rvhP ./ /usr/src/rtl88x2bu-${VER}
sudo dkms add -m rtl88x2bu -v ${VER}
sudo dkms build -m rtl88x2bu -v ${VER}
sudo dkms install -m rtl88x2bu -v ${VER}
sudo modprobe 88x2bu

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .