1

I am trying to install gnupg from source code using the following method:

step 1:

I cd to the uncompressed gunpg-2.2.10

cd Downloads/gnupg-2.2.10

step 2:

I run command :

./configure

step 3:

I run command

make

also I installed the libgcrypt as follow before the previous steps as follow:

step 1:

I cd to the libgcrypt uncompressed folder

step 2:

I run

sudo ./configure

step 3:

I run :

sudo make

step 4:

I run

sudo make install

but every time I go to the folder gnupg-2.2.10/g10 and run

./gpg

I get

 gpg: Fatal: libgcrypt is too old (need 1.7.0, have 1.6.5)

now here is the output of ls /usr/local/lib

libassuan.la        libgcrypt.so.20         libksba.la         libnpth.so.0
libassuan.so        libgcrypt.so.20.2.3     libksba.so         libnpth.so.0.1.2
libassuan.so.0      libgpg-error.la         libksba.so.8       python2.7
libassuan.so.0.8.1  libgpg-error.so         libksba.so.8.11.6  python3.5
libgcrypt.la        libgpg-error.so.0       libnpth.la
libgcrypt.so        libgpg-error.so.0.24.3  libnpth.so

please tell me what are the needed commands to fix this error? and please note I am not linux expert

1

Try

export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH

./gpg

  • I can confirm this does make gpg run but it's still not great since it appears during the Makefile it's not using the libgcrypt-config tool correctly (it complains about the system version of libgcrypt even when a source version is installed to /usr/local) – Kristopher Ives Sep 28 '18 at 19:50
  • 1
    Yes, Kristopher. I also think it is not ideal. I couldn't comment the question (joined 2 days ago), only answer. Now i can comment too. But if it will work for the user i hope it narrows the problem and final and ideal solution will be found. Thank you for the comment. Regards. – user875457 Sep 28 '18 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.