I am running Ubuntu 16.04 at work, and would like to upgrade to 18.04.

$ uname -a
Linux superbock 4.15.0-34-generic #37~16.04.1-Ubuntu SMP Tue Aug 28 10:44:06  UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

When I get the upgrade windows as follows:

enter image description here

I click on Upgrade... but nothing happens.

I tried running the update manager on the command line using

$ update-manager

When I click Update..., it says on the console

Error checking for authorization com.ubuntu.release-upgrader.release-upgrade: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying

I also tried using the do-release-upgrade command:

$ sudo apt update
$ sudo apt upgrade
$ sudo apt dist-upgrade
$ sudo apt-get autoremove
$ sudo apt install update-manager-core
$ sudo do-release-upgrade

And I get the following :

Checking for a new Ubuntu release
Get:1 Upgrade tool signature [819 B]                                                                                                                               
Get:2 Upgrade tool [1,258 kB]                                                                                                                                      
Fetched 1,259 kB in 0s (0 B/s)                                                                                                                                     
authenticate 'bionic.tar.gz' against 'bionic.tar.gz.gpg' 
gpg exited 1
Debug information: 

gpg: Signature made Wed 29 Aug 2018 19:33:13 BST using RSA key ID C0B21F32
gpg: /tmp/ubuntu-release-upgrader-ahhadl1h/trustdb.gpg: trustdb created
gpg: BAD signature from "Ubuntu Archive Automatic Signing Key (2012) <ftpmaster@ubuntu.com>"

Authentication failed
Authenticating the upgrade failed. There may be a problem with the network or with the server. 

Not sure what is going on? Could someone advise on how to get this sorted?

  • Could it be something similar to this ubuntuforums.org/showthread.php?t=2068667 ? – Terrance Sep 28 '18 at 14:00
  • @Terrance Seems to have worked, I do not get the error any more. I will run it on Monday though as I won't have time to make the upgrade tonight before going home. – Bentaye Sep 28 '18 at 14:33
  • @Terrance I managed to successfully run the upgrade today thanks to the link you provided. I wrote an answer explaining it. Cheers! – Bentaye Oct 1 '18 at 10:05

Thanks to Terrance comment in my original post, I managed to fix it. The problem was that gb.archive.ubuntu.com was not accessible.

It is configured here (the drop down saying Server for United Kingdom): enter image description here

It would not allow me to change it to be the Main server. Even running the update-manager as root so I had to do it manually in the /etc/apt/sources.list file.

Once replacing all the occurrences of http://gb.archive.ubuntu.com by http://archive.ubuntu.com in /etc/apt/sources.list the update manager is now set to the Main server download source:

enter image description here

After that, the update goes on with no issues.

  • Ran into nearly the same issue a few minutes ago, while updating a Ubuntu LTS 16.04.x server to 18.04 using do-release-upgrade. I used the official german mirror, after striping every de. from /etc/apt/sources.list, I did not run into any trouble anymore. – Robert Heine Nov 6 '18 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.