1

I use Ubuntu 18.04 Mate Edition with installed Unity. I've got several keyboard layouts and they're switching nice in Mate, but when I try to do it in Unity (upd: by shortcut) nothing happens. I've configure both Mate and Unity settings.

Unity Mate

ptrknvk@stiven:~$ cat /etc/default/keyboard
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

ptrknvk@stiven:~$ gsettings get org.gnome.desktop.input-sources xkb-options
@as []
  • Mate screenshot can't for some reason show the all list, but it's the same "Super+Space" shortcut. – Patrik Novák Sep 28 '18 at 12:25
  • Does it work in Unity if you click the input source indicator in the top bar and change layout that way? – Gunnar Hjalmarsson Sep 28 '18 at 16:07
  • Yes, but I rather use hotkeys. – Patrik Novák Sep 29 '18 at 21:37
  • Ok, then it's really a shortcut problem, right? Please edit your question and let us know what these two commands output: 1. cat /etc/default/keyboard 2. gsettings get org.gnome.desktop.input-sources xkb-options – Gunnar Hjalmarsson Sep 29 '18 at 21:57
  • Edited. See a post. – Patrik Novák Sep 30 '18 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.