I'm new at Ubuntu so I don't know very well how to use the terminal in order to download and install programs that aren't in the software center. I've tried without success downloading and installing Handbrake.

Could anybody help me, guiding me through the downloading and installation of Handbrake?

  • Please excuse my complete lack of understanding on how Ubuntu works, but how do you "run" said programme? Is it alt+F2 and then enter "sudo add-apt-repository ppa:stebbins/handbrake-releases"? What should happen after this? Really can't get my head around Ubuntu at all!
    – user151881
    Apr 24 '13 at 22:13
  • Note that the accepted answer is now outdated. Handbrake is in the main repositories under "Universe and no PPA is required". See the answer below for full details. Jul 9 '14 at 19:23

There are two official HandBrake PPAs, ppa:stebbins/handbrake-releases and ppa:stebbins/handbrake-git-snapshots.

The former contains stable releases, which are updated about once a year. These releases tend to be rather out-dated when their end-of-life is approaching. The current stable version (0.9.8) was released on 2012-07-18.

The latter contains nightly builds, which are updated daily (or nightly, as it were). These are of course less stable, and undocumented to boot, but they are good software nonetheless. Additionally, as the stable release ages, the developers tend to start recommending users to try the nightly builds instead.

To add one of these to your sources, simply run:

sudo add-apt-repository ppa:stebbins/handbrake-releases


sudo add-apt-repository ppa:stebbins/handbrake-git-snapshots

depending on which you want. To install HandBrake with the GUI, run:

sudo apt-get update
sudo apt-get install handbrake

Alternatively, if you would prefer the CLI (command-line interface) over the GUI, replace the last line with:

sudo apt-get install handbrake-cli
  • The -releases PPA doesn't seem to offer amd64 packages. Despite appearing in Launchpad's list of Quantal packages, Synaptic only shows the i386 packages, which won't install. Weird.
    – detly
    Apr 10 '13 at 10:09
  • That is quite the comprehensive and concise answer, my most sincere regards to you sir :D
    – sinekonata
    May 12 '13 at 23:27
  • If you see only mkv file format option and missing mp4 then install handbrake like this https://askubuntu.com/a/473520 Mar 4 '18 at 19:15

The handbrake ppa has been updated with the latest version of handbrake.


To install copy/paste the next lines of codes one by one in your gnome-terminal

sudo add-apt-repository ppa:stebbins/handbrake-releases
sudo apt-get update
sudo apt-get install handbrake-cli handbrake-gtk

Currently supports: Raring (13.04), Quantal (12.10), Precise (12.04), Oneiric (11.10), Natty (11.04), Maverick (10.10), Lucid (10.04), Karmic (9.10).

Note: You can still install the latest version of handbrake on Ubuntu 13.10, by manually downloading the appropriate .deb files:

I managed to install them on my Ubuntu 13.10 amd64 without issues

From source

If you want to compile it from source, here is what worked for me:

first install dependencies.

sudo apt-get install bzr subversion yasm build-essential \
autoconf libtool zlib1g-dev libbz2-dev libfribidi-dev \
intltool libglib2.0-dev libdbus-glib-1-dev libgtk2.0-dev \
libgudev-1.0-dev libwebkit-dev libnotify-dev \
libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev

Then download and compile

bzr branch lp:handbrake
cd handbrake
cd ./build
sudo make
sudo make install



HandBrake is available in the Ubuntu Software Center, search for it

enter image description here

If you have not made any changes to your Software Sources, you should be directed to an install page instead of what is in the above image. To add the "universe" source to your sources, go to Edit>Software Sources and check under the tab Ubuntu Software the "Community-maintained free and open-source software (universe)" and close.

enter image description here

Or just click the button to use that source.


Handbrake doesn't have any ppa support in 12.04. If you've tried adding the PPA's and still get the error, this solution resolved the problem for me

sudo rm /etc/apt/sources.list.d/stebbins-handbrake-*
sudo apt-get update

sudo apt-add-repository ppa:stebbins/handbrake-snapshots
sudo apt-get update

sudo apt-get install handbrake-gtk handbrake-cli

You need to do the update process twice, first time to remove the invalid ppas from the hit list, and the second time adds the correct PPA.

  • 3
    I'm not sure exactly what you're trying to do, but sudo rm stebbins-handbrake-* /etc/apt/source.list.d/ seems like wrong syntax. If your intention is to remove files that match stebbins-handbrake-* and are located in /etc/apt/sources.list.d/, it will not do that. (sudo rm /etc/apt/sources.list.d/stebbins-handbrake-* will.) Jul 16 '12 at 20:02
  • This worked perfectly for me. I had already tried to install Handbrake under 13.10 but it wasn't working. I removed the existing release source, added the snapshots and then installed handbrake without issue.
    – revnoah
    Nov 18 '13 at 23:02

I had to add these packages to compile on Ubuntu 12.04 LTS:

sudo apt-get install libass-dev libtheora-dev libvorbis-dev libsamplerate-dev

The binary is then in build/gtk/src (ghb), and you can run it directly without using makeinstall.


None of the previous solutions worked for me with Ubuntu 13.10. The one involving "bzr" fell over with:

../libhb/decssasub.c:30:21: fatal error: ass/ass.h: No such file or directory
 #include <ass/ass.h>
compilation terminated.
make: *** [libhb/decssasub.o] Error 1

However I managed to get it working by downloading directly and installing using dpkg. (taken from http://ubuntuhandbook.org/index.php/2013/10/install-handbrake-in-ubuntu-13-10-saucy/)

For 32-bit:

wget https://launchpad.net/~stebbins/+archive/handbrake-releases/+files/handbrakegtk_0.9.9ppa1~raring1_i386.deb

For 64-bit:

wget https://launchpad.net/~stebbins/+archive/handbrake-releases/+files/handbrakegtk_0.9.9ppa1~raring1_amd64.deb

Then install sudo dpkg -i handbrake-gtk_0.9.9ppa1~raring1_*.deb

and fix dependencies sudo apt-get -f install

Please tell me in the comments if you know what library I'm missing for the "bzr" option to work. I've got a fairly new Ubuntu install.

Cheers, Stuart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.