1

I have a C++ program that uses SDL library. The program is working fine on OSX but not on Ubuntu Mate 18.04 bionic running on odroid.

The error is something like no topmenu-gtk-module cannot be found. I tried to install topmenu as

sudo apt install libtopmenu-gtk*

but cannot be found in any repository.

How to install these libraries on Ubuntu Mate? Or which is the correct repository to be added?

  • Do you have clean installation of UM 18.04 or have upgraded from 16.04 LTS? – N0rbert Sep 28 '18 at 8:33
  • no I did an upgrade – Francesco Boi Sep 28 '18 at 8:58
  • @FranscesoBoi Then see my answer below. – N0rbert Sep 28 '18 at 9:40
0

Both topmenu-gtk2 and topmenu-gtk3 packages are not available for 18.04 LTS.

You can override GTK modules for your application in the terminal with

GTK_MODULES="canberra-gtk-module" /path/to/your-app

or by editing its .desktop file

env GTK_MODULES="canberra-gtk-module" /path/to/your-app

As you have upgraded from Ubuntu MATE 16.04 LTS to Ubuntu MATE 18.04 LTS then it may be other issue (see this post on ubuntu-mate.community - you need to remove one file manually:

sudo rm /etc/X11/Xsession.d/99mate-environment

and then reboot.

  • so is it sufficient to remove the file and skipping the lines above? – Francesco Boi Sep 28 '18 at 10:55
  • You can try both methods. File removal will fix future issues. – N0rbert Sep 28 '18 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.