0

I'd like to use a location different to my home directory for recording videos using SimpleScreenRecorder. However, when I "Browse..." File -> Save as: I get the following error message:

Could not read the contents of media
Error opening directory '/media': Permission denied

as soon as I browse into '/media' folder.

I already changed ownership of the folder from root to $USER, still the same. When I try to launch the application from the terminal using sudo or gksudo it fails to launch the application with

sudo

mkdir: cannot create directory '/run/user/0': Permission denied

gksudo

(gksudo:19480): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
No protocol specified
simplescreenrecorder: cannot connect to X server :0

I am using Ubuntu 16.04.

Everything works fine when I use my $HOME directory. I'd prefer to use the application without root permissions if possible.

For testing only I temporarily set /media permissions to 777 and it still did not work.

Please advice, thank you

  • What is your Ubuntu version and flavour? Are you by any chance in a Wayland session by any chance? What is the output of the following command in Terminal: echo $XDG_SESSION_TYPE? – pomsky Sep 27 '18 at 20:42
  • it is Ubuntu 16.04. I already tried sudo chown $USER:$USER /media but since @kukulo suggested I run again with -R. Took a while but no difference. $XDG_SESSION_TYPE is x11. I don't use wayland sessions AFAIK. – TheUltimateSource Sep 27 '18 at 21:51
0

You can use the chown command:

sudo chown username:username -R /media/

Replace username with your username.

  • For details see man chown. – kukulo Sep 27 '18 at 17:58

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.