7

I have ASUS X555SJ laptop, heaphones of smartphone, and combo port for both mic and headphones, but my PC keeps using internal mic and I am unable to change that. I have nothing in my System Settings, and tried with "Jack Retasking", "Pavucontrol", but unsuccesful. Any ideas how to fix this?

# cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC3236
Codec: Intel Braswell HDMI
7
  • Anyone? Anything?
    – EtexKG
    Sep 30 '18 at 2:54
  • Considering that only 15 folks have clicked on your question in 2 days, I counsel patience.
    – user535733
    Sep 30 '18 at 5:51
  • Heeeeeeeeeeeelp
    – EtexKG
    Oct 3 '18 at 22:11
  • Can you post an image of: goto settings -> sound -> click on input tab : make screenshot with alt+print
    – abu_bua
    Oct 7 '18 at 18:02
  • Post the output of cat /etc/modprobe.d/alsa-base.conf, btw: did you blacklisted sth?
    – abu_bua
    Oct 7 '18 at 18:09
5

I have solved the problem. What I did to do so is I went to HDA Jack Retasking, selected Realtek codec, checked "Show unconnected pins" on the right panel, overrided Pin ID 0x18 & 0x19 with selection of Microphone, and applied settings on the bottom right.

HDA Jack Retask

After that, I went to pavucontrol > Input Devices and changed port to "Microphone (unplugged)":

Pavuconrol

and this actually solved my problem. Hope it helps someone! :)

2
  • 1
    This didn't work for me, but overriding just 0x19 did.
    – user138737
    Apr 20 '20 at 23:55
  • It worked for me on my Asus Vivobook with Ubuntu 18.04. Thanks! Aug 8 '20 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.