1

I just installed a fresh version of Ubuntu 18.04 Desktop. Since then, when my computer goes to sleep/hibernate it does not wake up. 5 min. I have tried changing the sleep time to never, but it still does. Also my brightness slider has no effect on my screen brightness, don't know if that's related, but it would be nice to fix that too.

UPDATE
I did the update but still no luck. Here is the output from requested commands: lspci

00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1c.6 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #7 (rev f1)
00:1c.7 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #8 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1d.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #13 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev    31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GM204M [GeForce GTX 970M] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GM204 High Definition Audio Controller (rev a1)
3b:00.0 Ethernet controller: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller (rev 10)
3c:00.0 SD Host controller: Realtek Semiconductor Co., Ltd. RTS5250 PCI Express Card Reader (rev 01)
3d:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM951/PM951 (rev 01)
3e:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)


*-cpu                     
   description: CPU
   product: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
   vendor: Intel Corp.
   physical id: 1c
   bus info: cpu@0
   version: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
   serial: To Be Filled By O.E.M.
   slot: U3E1
   size: 2860MHz
   capacity: 4200MHz
   width: 64 bits
   clock: 100MHz
   capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf tsc_known_freq pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch cpuid_fault epb invpcid_single pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm mpx rdseed adx smap clflushopt intel_pt xsaveopt xsavec xgetbv1 xsaves dtherm ida arat pln pts hwp hwp_notify hwp_act_window hwp_epp flush_l1d cpufreq
   configuration: cores=4 enabledcores=4 threads=8
*-display
   description: VGA compatible controller
   product: GM204M [GeForce GTX 970M]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
   configuration: driver=nouveau latency=0
   resources: irq:124 memory:db000000-dbffffff memory:b0000000-bfffffff memory:c0000000-c1ffffff ioport:e000(size=128) memory:c0000-dffff
  • did you install all your updates after installing Ubunu? sudo apt update && sudo apt upgrade ? can you post some info on your system? perhaps lspci and sudo lshw -class video -class cpu – Joshua Besneatte Sep 27 '18 at 2:01
  • @JoshuaBesneatte added those outputs in the question – mmaceachran Sep 27 '18 at 14:51
1

Install the intel Microcode Package for your MB/CPU

Looks like you have an Intel board and might want the microcode for it:

 sudo apt install intel-microdcode

Next, make sure you have the latest Video Drivers

Updated graphics drivers, when using NVIDIA cards, will fix many problems, and so it is a good place to start. I see you are using the open source "nouveau" driver, so we will start with updating that. First add the PPA to provide latest drivers:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo apt upgrade

Now reboot and see if it works for you. If so, you are done! If not, try using the PRO drivers:

Install NVIDIA Pro Drivers (Optional)

If the latest neoveau drivers don't work, you can try the pro drivers instead. There are two options, 390 and 396. The 396 breaks my system, so I will give instructions on how to install 390 as well as how to try the 396 (and fix if needed).

To install the 390 driver:

sudo apt install nvidia-driver-390

And then reboot to test your system... if it works you can either stick with that or try the 396 diver:

sudo apt install nvidia-driver-396

And reboot... if this driver prevents X from starting, switch to a new TTY with "Ctrl+Alt+F3", log in and do the following:

sudo apt purge nvidia-driver-*
sudo apt autoremove && sudo apt autoclean
sudo apt install nvidia-driver-390
sudo reboot
| improve this answer | |
  • 2
    Thank you! I have been having this problem for months now. The sudo apt install nvidia-driver-390 did the trick for me. – jaycode Jun 10 '19 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.