3

I just got my new laptop Acer Aspire 7 A717-72G and of course Ubuntu is the first thing to set up on it but right now the mission is impossible ...

After the flash drive has boot up and an option live CD or Install is choosed it starts to load as usual and after a moment the Ubuntu GUI is shown but after approximately 10 seconds everything freeze up and only the cursor is working (cannot click anywhere).

I've changed all the options in the bios, disabled everything including the secure boot and nothing ...

Notice that only UEFI is supported, no legacy or something, this cannot be changed.

After everything I decided to try windows 10 ... and it worked. But I still cannot install Ubuntu, tried (16.04, 17, 18 (latest) ...)

Summarize:

Laptop: Acer Aspire 7 A717-72G

Need: To install Ubuntu (latest)

Problem: GUI freeze after approximately 10 seconds

Bootable flash drive: Tested on another machine and it works correctly

Update:

Thanks to @oldfred, I successfully installed Ubuntu this way:

  • Boot flash drive
  • Choose install option
  • Hit e and replace quiet splash with nomodeset
  • After installation finished and PC has reboot you must open the GRUB loader with esc or shift
  • Choose Ubuntu and hit again e
  • Again replace quiet splash with nomodeset to run the new system
  • Hit F10 (if i remember) to continue boot
  • Now after your OS is loaded - open software & update -> Additional Drivers
  • Install NVIDIA latest driver
  • Reboot PC
  • Restore BIOS settings to default ... (if you want)
  • That's all
  • 1
    Typically with nVidia, you need nomodeset to install & first boot or until you install proprietary nVidia driver from Ubuntu repository. And all Acer will need You to set "trust" on ubuntu/grub .efi boot files after install with Secure Boot on. But to install nVidia driver, secure boot will have to be off. Older, but otherwise similar: askubuntu.com/questions/627416/… & askubuntu.com/questions/162075/… – oldfred Sep 26 '18 at 22:00
  • Yes you are maybe right, I will give a try later on that. – Codew Sep 26 '18 at 22:31
  • @oldfred It worked, thanks! I updated my question. – Codew Sep 27 '18 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.