2

I am using XUbuntu 18.04 and I am struggling to install my scanner. I have tried everything i have been able to find on both Brother homepage and AskUbuntu. I have newest brsaneconfig4, brscan-skey and rules.

Command brsaneconfig4 -q returns:

(...)
Devices on network
0 DCP-7055W           "DCP-7055W"         I:192.168.1.28

Command scanimage -L returns:

device `brother4:net1;dev0' is a Brother DCP-7055W DCP-7055W

While command brscan-skey -l returns:

DCP-7055W         : brother4:net1;dev0  : 192.168.1.28         Not responded

I have libsane-brother4.so installed in /usr/lib64/sane, /usr/lib/sane and /usr/lib/x86_64-linux-gnu/sane

Command dpkg -l | grep Brother returns:

ii  brother-udev-rule-type1               1.0.2                               all          Brother udev rule type 1
ii  brscan-skey                           0.2.4-1                             amd64        Brother Linux scanner S-KEY tool
ii  brscan4                               0.4.6-1                             amd64        Brother Scanner Driver
ii  dcp7055wcupswrapper:i386              3.0.1-1                             i386         Brother DCP-7055W CUPS wrapper driver
ii  dcp7055wlpr:i386                      3.0.1-1                             i386         Brother DCP-7055W LPR driver
ii  printer-driver-brlaser                4-1                                 amd64        printer driver for (some) Brother laser printers
ii  printer-driver-ptouch                 1.4.2-3                             amd64        printer driver Brother P-touch label printers

and my libsane file has following content:

#
#   udev rules 
#

ACTION!="add", GOTO="brother_mfp_end"
SUBSYSTEM=="usb", GOTO="brother_mfp_udev_1"
SUBSYSTEM!="usb_device", GOTO="brother_mfp_end"
LABEL="brother_mfp_udev_1"
SYSFS{idVendor}=="04f9", GOTO="brother_mfp_udev_2"
ATTRS{idVendor}=="04f9", GOTO="brother_mfp_udev_2"
GOTO="brother_mfp_end"
LABEL="brother_mfp_udev_2"
ATTRS{bInterfaceClass}!="0ff", GOTO="brother_mfp_end"
ATTRS{bInterfaceSubClass}!="0ff", GOTO="brother_mfp_end"
ATTRS{bInterfaceProtocol}!="0ff", GOTO="brother_mfp_end"
#MODE="0666"
#GROUP="scanner"
ENV{libsane_matched}="yes"
#SYMLINK+="scanner-%k"
LABEL="brother_mfp_end"

I have tried everything without any significant success. At some point I have had working scanner, but after reboot it was no longer visible in SimpleScan. How can i make this work? What is missing?

1
  • Looks like you are doing remote scan, on which machine you are doing which command? – benni Apr 27 '19 at 13:16
4

I came across the posting Brother MFC-L2700DW printer can print, can’t scan by oscar1919 on Ask Ubuntu. I have a Brother multi-function printer but a different model than that specified by Oscar.

Oscar indicated that some of the installation files may be copied into the wrong folder. For 64-bit Linux, the instructions were to check that the folder /usr/lib/x86_64-linux-gnu/sane exists.

However, In my case, this folder was indeed present, but it was empty. The subsequent instructions were, essentially to copy the files libsane-brother* from the /usr/lib64/sane/ folder to /usr/lib/x86_64-linux-gnu/sane.

On my system, the three files to be copied were: libsane-brother2.so, libsane-brother2.so.1 and libsane-brother2.so.1.0.7.

Once these files were located in the /usr/lib/x86_64-linux-gnu/sane folder, Simple Scan sprung to life and scanned a test document.

1
  • 1
    Hi, unfortunately this is not the solution. I have already had libsane in every possible location. – Karol Pokomeda Sep 26 '18 at 21:10
2

Additional answer here which works on every Ubuntu version so far.

On brother website, there's a package that does that's called "Driver install tool".

  1. download it
  2. run in terminal
  3. provide your model by typing it's name i.e: DCP-9015CDW

follow the installer to also install a scanner drivers after printer is done. After the installer is done, simplescan will pick the scanner up without reboot.

The only "catch" is: if you want to install it over WiFi, make sure your printer has a static IP assigned on your router, and use that IP during install (one of the options is to provide the installer with the IP of the machine). If the IP of the driver changes, there's a chance you will have to redo your brsaneconfig everytime that happens so it's better to assign static IP to the printer/scanner.

Had no issues since.

Example download page for DCP-9015CDW: https://support.brother.com/g/b/downloadlist.aspx?c=gb&lang=en&prod=dcp9015cdw_eu&os=128 (listed under "Utilities" section)

2
  • I made it work with my DCP-L3550CDW by using the script provided by brother. During the installation process it was crucial for me to specify the IP. If I didn't specify the IP no scanning was possible (even though printing would work fine). – Philipp May 4 '20 at 10:19
  • 1
    yes, if this was over WIFI connection then you NEED to provide IP manually. Only cable connection works fine without providing IP manually. – Jan Myszkier May 4 '20 at 10:30
1

Adding your username to the group that owns the scanner, lp in my case, may also be needed.
sudo adduser $USER lp.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.