2

I'm trying to install Ubuntu 18.04 (18.04.1 will try tomorrow) onto Acer Aspire A315-41-R8XR. I have unpacked iso file to my flash and booted to grub successfully, but when I select "Try Ubuntu", I just get black screen and that's all. I have also tried to select "Install Ubuntu", but I get many errors:

enter image description here
Google: watchdog: BUG: soft lockup - CPU#1 stuck for 22s! [migration/1:15]

Windows 8.1 works fine, although it was already on the disk from another notebook, so, I think, it is not a power supply problem.

I've seen many such posts in the internet. It seems that people lost Ubuntu on Ryzen with Vega...

How to fix? May be use newer kernel? How to do it?


1

I had the exact same problem, there is some error in BIOS, I followed instructions from this article:

http://kulminaator.blogspot.com/2018/06/linux-on-amd-ryzen-2500u-powered-laptop.html

in grub menu while booting press "e" to edit booting parameters and edit as specified in the link.

It worked for me. Good luck! ;-) D.

0

first boot using nomodeset as kernel parameter, to do that boot in grub press e then add nomodeset after quiet splash then press F10 to boot.

If you are in legacy mode then select options and then check nomodeset.

then upgrade to latest mainline kernel or kernel newer that 4.19.0 and reboot.

kernel 4.19.0 included with support for ryzen mobile series and vega graphics however implementation is not yet complete you will experience random freezes at least once a day.

0

In Windows, insert the Ubuntu ISO image and open file explorer. Locate the boot folder and open the Grub config file with NotePad++. Edit the bootline of Try Ubuntu and/or Install Ubuntu : Locate the linux line,add a space at the end and type iommu=soft . Save, wait and exit. This change is permanent and it allows you to boot and compile custom Kernel (Ubiquity hot fix).

Example for Mint Tessa Compatibility Mode bootline:

linux    /casper/vmlinuz  file=/cdrom/preseed/linuxmint.seed boot=casper xforcevesa iso-scan/filename=${iso_path} ramdisk_size=1048576 root=/dev/ram rw noapic noacpi nosplash irqpoll -- iommu=soft

NB On Ryzen 2700U here, Linux ISO's will boot that way only.

cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.0.0-050000rc7-generic root=UUID=b6976dd1-ba78-4edc-9b49-4af79a979223 ro iommu=soft quiet splash vt.handoff=1

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.