42

the HDMI port of my lenovo ideapad 500s with Ubuntu 18.04 LTS is not working.

I also executed the xrandr command, but only the primary monitor is detected.

How can I solve my problem?

How can I check that HDMI is not broken?

Thanks in advance.

2
  • Concerning your second question about your HDMI cable, please try out, if you have the same problem when starting from a live-cd/usb of ubuntu.
    – BenSower
    Jan 2, 2019 at 15:46
  • 1
    Fix for me on ubuntu 20.04 (I have 2HDMI and 1 DP, second HDMI was not detected) 1. shut down 2. plug in only the second HDMI that was not being detected 3. start computer 4. plug in the other monitors Jan 7 at 9:20

14 Answers 14

45

The same thing happened to me but I was able to solve it. My solution was:

  1. Turn off the PC.
  2. Disconnect the HDMI cable.
  3. Turn on the PC (without HDMI).
  4. Log in.
  5. Reconnect the HDMI cable.
10
  • 1
    Had the problem after an upgrade to 19.10. This solves my issue.
    – clement g
    Oct 28, 2019 at 8:25
  • 4
    Ubuntu 20, this solves my issue.
    – littleguga
    May 26, 2020 at 20:06
  • 1
    On Ubuntu 20.04 with a Dell, this solved my problem. Last week my computer stalled while shutting down, and then after that my HDMI wasn't outputting. This brought it back
    – Cameron
    Jun 16, 2020 at 19:07
  • 1
    Ubuntu 20.04 Acer, itʼs helped me Jun 23, 2020 at 9:09
  • Linux Mint 20, this solves my issue too. Oct 15, 2020 at 11:27
22

How can I solve my problem?

What worked for me (Lenovo thinkpad x1 Carbon, Ubuntu 18.04 LTS), is either switching the display manager back and forth between gdm3 and lightdm

sudo dpkg-reconfigure gdm3

and/or reinstalling lightdm and reconfiguring it again instead of using gdm3

sudo apt-get install --reinstall lightdm ubuntu-desktop
2
  • 2
    I had to leave it in lightdm, because gdm3 starts flickering, thank you so much, I haven't had sleep well last 2 nights. Jun 20, 2019 at 6:03
  • 2
    I have the same laptop as you and I verified that I was using gdm3, and did the reconfigure as you suggested and it worked (require a reboot, since restarting the gdm3 service put it in flicker loop). I did not have to switch to lightdm. In my case I outputting video in HDMI and USB-C. Jun 24, 2019 at 13:16
6

In case you using Nvidia graphics card the nvidia-driver could be a problem.

In my case, I've been using my Lenovo Y530(GTX 1050 ti) with Ubuntu 18.04 with nvidia-driver 415.xx which hasn't been supporting the secondary monitor through HDMI. I've tried in many ways with no luck. I finally upgraded the driver to 418.39 and the secondary monitor began to work! :)

But be careful in case you decided to go and install the driver but are not used to. There are some scenarios which can harm your system which would eventually lead you to format the system.

3
  • have the same laptop as you and the same issue. It happened to me after updating my BIOS. I tried to use the newer drivers but did not seem to work for me. I followed these steps: ubuntuhandbook.org/index.php/2019/03/… Did you do it differently?
    – Vlad
    Jul 3, 2019 at 9:46
  • Yes. I need cuda alongside nvidia-drivers. So, I just downloaded .run file from CUDA Toolkit 10.1 Update 1 Download and installed using it.
    – David Jung
    Jul 15, 2019 at 5:34
  • Thanks a lot. I used your tip and the previous answer and now it works. So after removing all drivers, installing nvidia drivers i reconfigured and then reinstalled lightdm
    – Vlad
    Jul 28, 2019 at 21:21
3

In my case it was broken VGA -> HDMI adapter (finally it just burned out).

I suggest this steps to troubleshoot your problem.

  • try to reboot
    • disconnect cable
    • sudo reboot
    • after system start and log on - connect cable again
  • Check another HDMI cable
  • Check another Display/TV with current HDMI cable and different HDMI cable
  • If you use HDMI->VGA adapter - check it
  • lshw -C video - check that you have HDMI there, if not - try to check:
    • your laptop HDMI connector
    • different cables
  • check xrandr --listmonitors - that you have another display there
  • check which display manager you use
    • sudo systemctl status display-manager
  • try different display managers (gdm3 or lightdm)
    • sudo dpkg-reconfigure gdm3
3

Sharing my experience here, maybe it will help others.

My HDMI doesn't work after a BIOS update. I shut down the computer, and then manually disabled "Secure Boot" and "Fast Boot". I've disabled it before but it seems the BIOS update reset some settings.

Monitor works again after this.

1
  • 1
    That fixed my issue. I updated the BIOS and HDMI stopped working. Disabled secure boot and it works. FYI this is on a Lenovo laptop. Thanks!
    – ndstate
    Dec 3, 2020 at 17:06
2

In my case, the NVidia drivers where the trouble. When using the Noveau software the problem was solved! Thanks

1
  • 1
    Will just add for anyone reading this the nouveau drivers will probably cause problems elsewhere. In many applications I found the Nvidia drivers too work much better. So there is a trade of here. Expect new problems to pop up. I expect that in general Nvidia drivers are less troublesome.
    – Kvothe
    Jan 10 at 15:34
2

Sharing my experience:

  1. Upgrade 20.04 to 20.10 -> not fixed
  2. Reconfigured gdm3 -> not fixed
  3. Switch from gdm3 to lightdm and back to gdm3 -> not fixed
  4. Disconnect the cable, reboot, login, reconnect -> fixed ( @littleguga solution )
1
  • all same bu number 4 not worked as well for me :( Sep 14, 2021 at 9:08
2

Form my situation (Ubuntu 20.04 Dell-5500) my problem was about UEFI Secure Boot.

Did these and worked for me:

1- Open a terminal (Ctrl + Alt + T), and execute sudo mokutil --disable-validation.

2- Enter a temporary password between 8 to 16 digits. (For example, 12345678, we will use this password later

3- Enter the same password again to confirm.

4- Reboot the system and press any key when you see the blue screen (MOK management

5- Select Change Secure Boot state

6- Enter the password you had selected in Step 2 and press Enter.

7- Select Yes to disable Secure Boot in shim-signed.

8- Press Enter key to finish the whole procedure.

Lastly to re-enable Secure Boot validation in shim, simply run sudo mokutil --enable-validation.

Solution link here : solution

2

What happened to me was that i got a kernel driver dependency not updated/installed.

I discovered it by running sudo ubuntu-drivers autoinstall on my terminal and recieving the following error message:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-driver-470 : Depends: nvidia-kernel-source-470 (= 470.86-0ubuntu0.20.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Simply installing the missing dependency (in my case nvidia-kernel-source-470) for my driver (nvidia-driver-470) and running the autoinstall again worked. So the steps were basically this:

  • Run sudo apt install nvidia-kernel-source-470
  • Run sudo ubuntu-drivers autoinstall again. Obs: Make sure you are using the correct driver, in my case nvidia-driver-470
  • Reboot and you are ready to go!

My specs:

  • SO: Ubuntu 20.04
  • Computer: Lenovo Ideapad Gaming 3i
  • Graphics card: Geforce GTX 1650

Hope it helped!

1

Same problem was on my Ubuntu 18.04.5 on Dell G3 3790 laptop. Fixed by changing "Ubuntu Wayland" to "Ubuntu" when pressing a small cogwheel on login screen.

0

I am using Ubuntu 20.04, one of my HDMI monitors suddenly stopped working after a restart and nothing I found online was making it work again. I unplugged both HDMI from the PC and plugged them back in the other way (slot 1 to 2, slot 2 to 1), and now it's working again, so I swapped them back to how they were.

0

I know this is old but nothing above works for me.

What finally do was switching the default display in the bios settings to HDMI and boot with it. If you see it working like me then you can reboot and put it as it was before and HDMI continued working as always.

I know it's not a really technical answer, maybe there is some configuration that broke and it's regenerated that way.

0
0

I am running Kubuntu 20.04, so this answer might be considered a bit off-topic. But I came over this post when looking for my problem, but in case someone else stumbles over this, I am posting this here. It might also work for other Ubuntu versions and derivatives.

I tried all the above solutions, and none of them worked. Turns out, that for some reason, the display was actually detected, but not activated.

To activate the display, I had to go to System Settings -> Display and Monitor -> Display Settings.

It will only show a single screen in the display diagram at the top of the window.

Now select the Device dropdown, select the second device and check the Activated checkbox and press Apply.

(The exact names of buttons and stuff might differ, I using a different language).

0

I've had the same "HDMI output not working" problem occur multiple times on a computer and I found a working solution.

It ended up being Ubuntu switched my graphics driver from a working proprietary one to a partially-working open source one (as in it doesn't work with a connected HDMI output). This switch most likely happened during an update.

So to fix that, I went to Settings -> About -> Software Updates and then chose the a "proprietary, tested" driver instead of the "open source" one.

Afterwards, I restarted the computer and the external HDMI output worked. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.