0

I have a gtx 1070 with Ubuntu 18.04 and I’d like to use tensorflow, which requires CUDA 9.0 which requires NVIDIA driver 384. I’ve had quite a bit of trouble installing drivers in the past, so I prefer to use the drivers GUI for updating my drivers. Ubuntu gives me the options of using 390, 396, or Nouveau drivers. I’m currently using 390, but since it’s incompatible with my cuda version I need to downgrade. I tried installing nvidia-384 from the ppa, but my system is still using 390 as the driver. I could apt remove purge the drivers but then I’m worried it’ll go back to Nouveau which is a headache to override. Is there a simple way to force Ubuntu to use version 384?

5
  • @Terrance Ubuntu support cuda 10 but tensorflow does not. Also I’ve tried the 390 driver with CUDA 9 and it says no driver is installed – A Tyshka Sep 25 '18 at 17:54
  • CUDA 10 is definitely not compatible, some people have had some luck building from source but it’s difficult. I just want the 384 driver for CUDA 9 – A Tyshka Sep 25 '18 at 19:42
  • Honestly, it looks like you didn't remove the 390 driver first before installing the 384. Try sudo apt remove nvidia-* before trying to install nvidia-384 – Terrance Sep 25 '18 at 19:51
  • Did you read my question? I stated I did NOT want to remove the newer drivers, because then Ubuntu defaults to Nouveau drivers which are a headache to deactivate. I want to simply change what the preferred driver is without removing them – A Tyshka Sep 25 '18 at 21:11
  • I have read your question. You said you want to downgrade, and that is how you do it. However, you could try using the Additional Drivers part of Sofware & Updates and just try selecting the 384 drivers if they are available and reboot that way. If it does not come up, there is a good chance that those drivers may simply not be compatible with Ubuntu 18.04. – Terrance Sep 25 '18 at 21:21
0

Actually, the compatibility is >=384 which includes 390: https://docs.nvidia.com/cuda/cuda-toolkit-release-notes/index.html For me the combination of Ubuntu 18.04, TensorFlow 1.11, Nvidia driver 390 and CUDA 9 works. But there was a problem I had to overcome first: By creating an Anaconda environment there was an incompatible cuDNN version (7.1.2) installed, which I had to overwrite manually with the system's version (7.3.1) I had previously installed.

btw: I was not able to install any other driver version than 390 on my system, although I removed this version before trying to install another one. But in the end it was not necessary.

1
  • Yeah I wasn’t able to install anything else either – A Tyshka Oct 17 '18 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.