Recently purchased the Dell Latitude 5495, installed Ubuntu straight away. Immediately started noticing some minor issues:

  • Mouse Pointer would randomly just freeze, like frozen, need to restart to fix.
  • Two finger scrolling does not work at all.
  • I tried going back to synaptic sudo apt install xserver-xorg-input-synaptics; sudo apt remove xserver-xorg-input-libinput

After removing libinput, unable to get keyboard and touchpad to work again. So formatted again (luckily it was a fresh install)

The keyboard is working again, but two-finger scrolling is still not working.

~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=15   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD: Integrate           id=10   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
    ↳ DELL Wireless hotkeys                     id=16   [slave  keyboard (3)]


~$ xinput list-props 15
Device 'PS/2 Generic Mouse':
    Device Enabled (138):   1
    Coordinate Transformation Matrix (140): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Natural Scrolling Enabled (273):   0
    libinput Natural Scrolling Enabled Default (274):   0
    libinput Scroll Methods Available (277):    0, 0, 1
    libinput Scroll Method Enabled (278):   0, 0, 1
    libinput Scroll Method Enabled Default (279):   0, 0, 1
    libinput Button Scrolling Button (280): 2
    libinput Button Scrolling Button Default (281): 2
    libinput Middle Emulation Enabled (282):    0
    libinput Middle Emulation Enabled Default (283):    0
    libinput Accel Speed (284): 0.000000
    libinput Accel Speed Default (285): 0.000000
    libinput Accel Profiles Available (286):    1, 1
    libinput Accel Profile Enabled (287):   1, 0
    libinput Accel Profile Enabled Default (288):   1, 0
    libinput Left Handed Enabled (289): 0
    libinput Left Handed Enabled Default (290): 0
    libinput Send Events Modes Available (258): 1, 0
    libinput Send Events Mode Enabled (259):    0, 0
    libinput Send Events Mode Enabled Default (260):    0, 0
    Device Node (261):  "/dev/input/event8"
    Device Product ID (262):    2, 1
    libinput Drag Lock Buttons (275):   <no items>
    libinput Horizontal Scroll Enabled (276):   1

I know for a fact this touchpad supports two-finger scrolling, as it was working in Windows.

No idea how to get two-finger scrolling to work. Also is there a list of known issues I should be aware of for Ryzen 5 Pro 2500U and the latest Ubuntu Kernel?

Pastebin of dmesg

  • Right, guess I am a bit ambiguous on what I'm trying to figure out haha. Sep 25, 2018 at 16:37
  • Wow, does touchpad work for you at all? You don't have touchpad in your xinput list, this is odd. The "Generic Mouse" you listed properties for is just that — a mouse. Do you see any output for dmesg | grep -i touchpad?
    – Hi-Angel
    Sep 25, 2018 at 17:36
  • @Hi-Angel nothing.. dmesg | grep -i touchpad returns noting. And it was very odd to me as well. But I just thought perhaps it's a mismatched device name or driver issue. Sep 25, 2018 at 18:13
  • grep -i touch /proc/bus/input/devices comes up with nothing either, does it? And while on it, can you post the output of dmesg? You can post it through some pasting site.
    – Hi-Angel
    Sep 25, 2018 at 21:08
  • @Hi-Angel I have updated the question to include a paste dmesg output Sep 25, 2018 at 23:29

2 Answers 2



Update your Ubuntu kernel to 4.15.0-36.39 or later by running:

sudo apt-get update
sudo apt-get dist-upgrade

Detailed Version

This was caused by a bug in the kernel. It was fixed in Ubuntu's kernel a few days after your question was asked. It looks like the patch was sent upstream to 4.18.0-8.9. See https://bugs.launchpad.net/ubuntu/+source/linux-oem/+bug/1773940 for more information.

I have tested the fix in Ubuntu 18.04 LTS. If you are on another distribution you will have to install kernel 5.2 or later (to be released in July 2019). In the meanwhile thanks to Syniurge we can install updated module through DKMS https://github.com/Syniurge/i2c-amd-mp2/ Please note that the updated driver cannot be installed on latest Ubuntu as the DKMS driver cannot override the built in driver.

If your module does not load modprobe: ERROR: could not insert 'i2c-amd-mp2': Operation not permitted after installing the module, make sure you have disabled secure boot in the BIOS

Edit: Updated kernel version with fixes are accepted.


Solved by unchecking "Disable touchpad while typing".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.