0

I run Ubuntu 18.04 on a Sony SVP laptop. It detects my WI-FI network but when I try to connect, it does not work. I tried to connect via iwconfig, but when I try to set the essid i get the following error message: 'Error for wireless request "SET ESSID" (8B1A) : SET failed on device wlp1s0 ; operation not permitted' When I used 16.04 on the same laptop the WI-FI connection worked without any problem. I know I am an early user of 18.04 but there must be some solution to this.

0

The solution was to use systemd instead of network manager. I used vi to create this file: /etc/netplan/03-wireless.yaml: network: version: 2 renderer: networkd wifis: wlp1s0: dhcp4: true access-points: "the SSID": password: "the password" (the SSID and the password shall be the actual SSID and password) I created the run time config file and applied the config: sudo netplan generate sudo netplan apply then I stopped and disabled network manager: sudo systemctl stop network-manager sudo systemctl disable network-manager then I enabled and started systemd-networkd sudo systemctl enable systemd-networkd sudo systemctl start systemd-networkd with the command networkctl I checked the status: networkctl and got this response: IDX LINK TYPE OPERATIONAL SETUP
1 lo loopback carrier unmanaged 2 wlp1s0 wlan routable configured

2 links listed. after this i restarted the PC but I don't think that was necessary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.