0

I just upgraded Ubuntu from 17 to 18.04. I regularly use 2 keyboards, but even if I change the keyboard layout from the Keyboard settings config window (no extras, the default one), the keyboard layout does not change. I mean, I can change the current layout, I can see the thumbnail changing in the taskbar, but such change does not affect the keyboard, which is always working with the same layout.

The only way I managed to change the layout is executing:

sudo dpkg-reconfigure keyboard-configuration

But it takes too long to generate the configs and change the layout (being used to just a click).

The output of "cat /etc/default/keyboard" is:

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="asus_laptop"
XKBLAYOUT="es"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

And the output of "gsettings get org.gnome.desktop.input-sources xkb-options" is:

@as []

Do you know what can I do to get back the missing functionality? Thanks in advance,

  • Please edit your question and show us the output of these two commands: 1. cat /etc/default/keyboard 2. gsettings get org.gnome.desktop.input-sources xkb-options – Gunnar Hjalmarsson Sep 25 '18 at 20:14
  • Done @GunnarHjalmarsson :) – gal007 Sep 25 '18 at 22:54
  • Ok, no explanation there. Did you see this page? – Gunnar Hjalmarsson Sep 26 '18 at 0:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.