1

I've just installed Eagle software in my Ubuntu 18.04. I extracted the file and place the folder in

/home/myusername/opt/

then run the eagle app from the folder. For the first time i can go through license agreement, login account and running the app. After exit the app then opening it for the second time (with double click "Eagle" icon) i got an error message said

"Can't write '/home/myusername/.local/share/Eagle/settings/9.1.3/eaglerc' (access denied)".

But if i open it from terminal from eagle app folder with

sudo ./eagle

then entering my password, the error not showing anymore. So my question is, how to open Eagle app from the icon without entering password in terminal? Thanks

  • try to change ownership as your username sudo chown <username>:<username> -R /home/myusername/opt/eagle-9.1.3/* and run again with ./eagle on package installation path – abu-ahmed al-khatiri Sep 25 '18 at 14:07
  • @abu-ahmedal-khatiri Thank's for the reply ahmed, but it still doesn't work. – Dwi Satrio W. Sep 25 '18 at 15:50
  • let i see what the console log said after run ./eagle? – abu-ahmed al-khatiri Sep 25 '18 at 15:52
  • I dont really understand how to do it, but is this correct paste.ubuntu.com/p/4WVpjRYh9p – Dwi Satrio W. Sep 25 '18 at 22:48
  • on the pastebin log said "Window manager warning: Invalid WM_TRANSIENT_FOR window 0x2e0001b specified for 0x2e00019 (Eagle)." that just tell you about window manager warning instead something permission issue like your question – abu-ahmed al-khatiri Sep 26 '18 at 8:48
0

"Can't write '/home/myusername/.local/share/Eagle/settings/9.1.3/eaglerc' (access denied)".

that log appears cause your don't have owned of your package. change it with chown.

one thing before you open it, remove your sets with type

sudo rm -rf /home/myusername/.local/share/Eagle/

after that, change owned your package.

sudo chown <username>:<username> -R /home/myusername/EAGLE/

and change directory of Eagle and launch it.

cd /home/myusername/EAGLE/
./eagle

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.