I just changed BorderlessMaximizedWindows setting in ~/.config/kwinrc to true to hide window title bar and it works, but after restart of my PC my kwin config is reset to default settings, so BorderlessMaximizedWindows is set to false again.

How to make these settings persistent after restart?

Output from inxi -Sxxx:

System:    Host: tomsk-U36SD Kernel: 4.15.0-33-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: KDE Plasma 5.13.5 (Qt 5.11.1) dm: sddm,sddm Distro: neon 16.04 xenial


The problem was with Latte Dock: Can I have different BorderlessMaximized windows option between different layouts?

  • 1
    @DKBose Thank you and config file is saved in ~/.config/latte/{profile_name} and the key is called disableBordersForMaximizedWindows.
    – tomsk
    Sep 26, 2018 at 13:16

1 Answer 1


(This answer is based on info found in the question and comments... writing this in case link stops working someday...)

My KWin setting for BorderlessMaximizedWindows started resetting after I installed Latte Dock on a few computers. Only one computer was affected. It is related to a feature that allows different dock layouts to have different border settings for maximized windows. (See Can I have different BorderlessMaximized windows option between different layouts?)

The following commands will return KWin to its previous behavior:

kwriteconfig5 --file ~/.config/lattedockrc --group UniversalSettings --key canDisableBorders false
latte-dock -r &

kwriteconfig5 --file ~/.config/kwinrc --group Windows --key BorderlessMaximizedWindows true
qdbus org.kde.KWin /KWin reconfigure

They correspond with unchecking "Support borderless maximized windows in different layouts" in the Preferences tab of the Latte Dock settings dialog.

latte dock settings 1

Alternatively, you can enable the setting and check the "Borderless" option (by double clicking) for the desired layouts in the Layout tab.

latte dock settings 2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .