5

After starting up my PC today I have noticed that all of the icons in both the Gnome desktop and in the Nautilus file explorer have all turned blank white, even the directory icons.

Desktop:

File explorer:

Restarting Gnome or rebooting the system doesn't help.
This is annoying and very disruptive, is there any way of fixing this without reinstalling Ubuntu?

Edit - Output of gsettings list-recursively | grep --ignore-case "icons":

org.gnome.desktop.background show-desktop-icons false
org.gnome.desktop.interface menus-have-icons false
org.gnome.desktop.interface toolbar-icons-size 'large'
org.gnome.desktop.interface buttons-have-icons false
9
  • have you did changes on any configurations? Oct 3 '18 at 9:11
  • @OkiErieRinaldi Nothing special or out of the ordinary. I've been using Ubuntu 18.04 on multiple machines for a few months now and this is the first time I came across such an issue.
    – Acidic
    Oct 3 '18 at 10:37
  • 1
    Can you please execute gsettings list-recursively | grep --ignore-case "icons" and edit the output to that into your question and then ping me @Fabby? :-)
    – Fabby
    Oct 3 '18 at 17:29
  • @Fabby Done, I've added the output to the question.
    – Acidic
    Oct 7 '18 at 7:58
  • 1
    Seeing that mu first hunch was incorrect: does this problem also persist in the guest session? If yes: no further ideas...
    – Fabby
    Oct 9 '18 at 9:21
6

Running the following commands fixed the issues, though I'm not sure if both are needed or if it's only one of them:

gsettings reset org.gnome.desktop.interface gtk-theme
gsettings reset org.gnome.desktop.interface icon-theme

This didn't change anything else other than restoring the icons, probably due to the fact that I never changed the theme to begin with – so I have to assume that some of the settings on my machine were badly configured and this reset them back to their defaults.

0
3

This also happened to me this week. After getting some updates, I lost folder icons and terminal changed to an odd icon.

This one worked fo me:

gsettings reset org.gnome.desktop.interface icon-theme
2

going to Tweaks app -> Appearance -> Icons and selecting "Humanity" worked for me

0

This can also be solved by opening the app tweaks and going to appearance. If you select an Icon listed lower than Highcontrast you have icons again. This is Ubuntu doesn't install all the icon packages available on the tweaks app by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.