0

I have a basic up to date install of 18.04 server. Only the universe repository has been added above the default installation. No third party repos.

When I try to install package lxc I get the following error:

lxc : Depends: lxc-utils (>= 3.0.0-0ubuntu2) but it is not going to be installed

So I try to install lxc-utils. But it also has broken dependencies:

lxc-utils : Depends: liblxc1 (= 3.0.0-0ubuntu2) but 3.0.1-0ubuntu1~18.04.2 is to be installed

Is this intentional, should I now be using something else for LXC capability?

  • Does sudo apt install -f help? – George Udosen Sep 24 '18 at 17:36
  • This kind of version mismatch should be fixed by a normal sudo apt update and sudo apt upgrade before trying to install lxc. – user535733 Sep 24 '18 at 17:41
  • System is fully up to date, both packages and repos. Am suspecting there's actually broken dependencies in the Bionic repos. – yaztromo Sep 25 '18 at 9:43
0

My problem was /etc/apt/sources.list

I thought that universe should be added separately to the default three lines

deb http://archive.ubuntu.com/ubuntu bionic main
deb http://archive.ubuntu.com/ubuntu bionic-security main
deb http://archive.ubuntu.com/ubuntu bionic-updates main
deb http://archive.ubuntu.com/ubuntu bionic universe

This is not right. It should look like this

deb http://archive.ubuntu.com/ubuntu bionic main universe
deb http://archive.ubuntu.com/ubuntu bionic-security main universe
deb http://archive.ubuntu.com/ubuntu bionic-updates main universe

There is a bug report against Bionic server installs missing universe https://bugs.launchpad.net/subiquity/+bug/1783129

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.