I have successfully created hotspot in Ubuntu to share my wired internet connection.

Newly formed connection works fine with WPA.

I edited hotspot connection using nm-connection-editor command.

When I change the ssid or WPA password and try to connect to hotspot it gives authorisation error. In the same case when I change the security to none it works fine.

I am using Ubuntu 18.04.1 LTS.

Also the hotspot config file (location:/etc/NetworkManager/system-connections/Hotspot) shows the following..

[connection]
id=Hotspot
uuid=a7ff7e83-72b8-479a-9445-7b2cf9e4dd78
type=wifi
autoconnect=false
permissions=

[wifi]
mac-address=74:DA:38:1A:C0:BD
mac-address-blacklist=
mode=ap
ssid=chetan-desktop

[wifi-security]
key-mgmt=wpa-psk
psk=Co0zdbbO

[ipv4]
dns-search=
method=shared

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto
up vote 1 down vote accepted

Try setting these specific parameters:

[wifi-security]
group=ccmp;
key-mgmt=wpa-psk
pairwise=ccmp;
proto=rsn;
psk=YOUR_WIFI_AP_PASSWORD

If you still get errors try viewing the log output to see what is failing:

sudo journalctl -u NetworkManager.service 
  • thanks a lot @kristopher by setting specific params its working. just one doubt why isnt these params are set implicitly ? is this a bug or any specific reason behind that ? – chetan Sep 24 at 12:29
  • 1
    My understanding is that by not setting it multiple methods of authentication are available and one that isn't working or supported is being picked. The implicit settings for these options (pairwise, group, and proto) leave many combinations to be explored and my guess is the connecting device is trying one then getting mad and giving up. – Kristopher Ives Sep 24 at 12:31

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.