I have an I7-8750H and currently have a dual boot machine with Win10 and Ubuntu 18.04 with the 4.18.8 kernel.

When I stress test all cores of the cpu in windows it reaches 3.9 GHz which is as it should, but when i stress test in Ubuntu, the cores only reach 2.5 GHz.

I have tried changing the scaling governor but doesn't change the outcome.

i7z says:

Socket [0] - [physical cores=6, logical cores=12, max online cores ever=6]
TURBO ENABLED on 6 Cores, Hyper Threading ON
Max Frequency without considering Turbo 2307.32 MHz (100.32 x [23])
Max TURBO Multiplier (if Enabled) with 1/2/3/4/5/6 Cores is  41x/41x/40x/40x/39x/39x
  • suggest to try (as tests); boot with hardware pstate control disabled, intel_pstate=no_hwp; does stress on only 1 cpu make a difference, i.e. go to near 4.1 GHz?; boot with the acpi-cpufreq driver, intel_pstate=disable; try kernel 4.19-rc5. What is your stress test method? Sep 24, 2018 at 14:18
  • I am ussing the stress command; With 1 and 2 cores it reaches 4.1 GHz, with 3 4.0 GHz, with 4 3.7GHz, with 5 3.2 GHz, with 6 3 GHz, with 7 2.9 GHz... etc; how can I do the boots you are refering to?
    – Jamidd
    Sep 24, 2018 at 17:11
  • Oh, you modify /etc/default/grub and change (for example) this line: GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 consoleblank=300" to this GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 consoleblank=300 intel_pstate=disable" and then do sudo update-grub and then reboot. Keep a copy of your original /etc/default/grub first. However, it seems to be working fine. Suggest making your own stress test, so that you know exactly what it is doing. Example: taskset -c 7 yes > /dev/null & repeat for all CPUs. killall yes to terminate them. Then you know it is CPU bound and not IO/disk limited. Sep 24, 2018 at 21:16
  • I created a infinite loop in c and ran 12 instances at the same time (12 threats at 100%). It ended up that the stress command was IO/disk limited, and the clock speed reached 3.2 GHz, but still not he 3.9 it should.
    – Jamidd
    Sep 24, 2018 at 22:13
  • tried intel_pstate=no_hwp and intel_pstate=disable, the first didn't make a diference at all, and the seccond usually stayed at 2.9 GHz and sometimes go to 3.2GHz
    – Jamidd
    Sep 24, 2018 at 22:32

1 Answer 1


For full answer see: Is Turbo Boost Working?

Is Intel Turbo Boost enabled?

Using the terminal you can check if Turbo Boost feature is enabled:

$ cat /sys/devices/system/cpu/intel_pstate/no_turbo

This is a double negative; when "no turbo" is off (=0) then Turbo Boost is on.

To disable Turbo Boost use sudo powers and set the switch no_turbo to 1:

$ echo "1" | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo

The returned 1 indicates turbo is now off.

I wrote cpuf to let you change the minimum and maximum frequencies to any within the allowable range:


Visit the link to copy the script or get more details.

  • 1
    Turbo Boost is enabled, if not it would top at 2.2GHz. When i run cat /sys/devices/system/cpu/intel_pstate/no_turbo it return 0. The problem is that i am not getting full turbo speed, not that it is not activated.
    – Jamidd
    Sep 24, 2018 at 13:16
  • 1
    I'll add the next step "scaling frequencies" when I get home Sep 24, 2018 at 15:05
  • 2
    @WinEunuuchs2Unix did you get home already? :D Jun 17, 2019 at 22:18
  • 2
    @LucasBustamante It was a long journey home :D Jun 17, 2019 at 23:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.