2

I installed the workspace grid extension for GNOME, which works like a charm.

I wonder how can I modify or get rid of the workspaces names which appear during the workspace changes (I use the ctrl+alt+arrow shortcuts). I could not find the option in the config menu of the extension, neither in the gnome-tweaks menu.

2
  • 1
    Do you want to "rename the workspaces" (title) or "get rid of the workspaces names" (body)? – pomsky Sep 23 '18 at 15:04
  • @pomsky Actually, my goal was to get rid of the workspaces names ; and I thought the easiest way to achieve that was to give them an empty name. Thanks for pointing the inconsistency, I'll edit the title & the question. – m.raynal Sep 24 '18 at 8:54
6

Use dconf (dconf-editor) to edit the /org/gnome/desktop/wm/preferences/workspace-names...

enter image description here

2
  • Works well, and it also has the advantage to prevent installing an extra extension, and thus depend on its updates. Giving ' ' as a name for each of the workspaces does actually keep the pop-up, and gets rid of the names, which was precisely my goal. – m.raynal Sep 24 '18 at 9:06
  • @m.raynal I'm glad that it worked for you! You can probably just use [] to eliminate the names, instead of ['','','','']. – heynnema Sep 24 '18 at 14:30
2

The easiest way to rename your workspaces is to install the (official) gnome extension Workspace Indicator. Through its configuration settings (you can access these in Gnome Tweaks), you can provide custom names for the workspaces. Just turn the extension off when done renaming if you do not want the workspace indicator in your panel.

In the body of your post, you mention you may want to get rid of the names altogether. That effect can be achieved by setting the name to a single space in Workspace Indicator.

As a bonus tip, perhaps you like an entire clean approach where no popup at all appears when you switch workspaces using the keyboard. To achieve that, install the Disable workspace switcher popup extension.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.