5

I am having an issue on Ubuntu 18.04 LTS where the computer will hard freeze with no detectable reason. This happens most frequently while I am away from the computer for extended periods of time (while asleep, for example) and I will return to a completely frozen computer. It accepts no input whatsoever, does not move the cursor when the mouse is moved, and tricks like REISUB do nothing. My only option is to turn off the computer with the power button.

Specs:
CPU: AMD Ryzen 5 1600
GPU: GeForce GT 1030
Mobo: Gigabyte AB350-Gaming-CF
RAM: Ballistix Sport LT 8GB x2
HD: Samsung SM961 SSD
PSU: Cooler Master Extreme Power RS-600-PCAR-E3

I have figured this may have been a hardware problem related to my video card, but replacing the card with the GT 1030 has only slightly abated the problem. Once or twice the computer has frozen while I was using it, but almost always while I was not directly touching the computer and turned away doing something in real life.

I've looked through the syslog file to see if anything is going on, but the computer appears to freeze before it can even write anything to syslog. I've also ran a memtest which came up 100% clean.

I've been having this issue since running 16.04 LTS as well. Upgrading has had no effect on the freezing issue.

I am using Cinnamon desktop environment.

  • What does your /var/log/syslog say around the time of a crash? – user535733 Sep 23 '18 at 12:55
  • Nothing. In the syslog before the most recent freeze, the last entry is a DHCPREQUEST which doesn't appear to have any issue. The syslog simply stops recording anything while the freeze occurs, and doesn't begin writing again until I reboot. – RevMungo Sep 23 '18 at 13:40
  • I might be off base here, but does the freezing seem to happen within the same amount of time each time? Also, do you have more than one screensaver installed? To check that try running apt list --installed | grep screensaver Unfortunately, troubleshooting hard freezing problems can be very extensive. I guess one other thing you could try to eliminate your software on your system as being the problem is to try running your system from a LiveCD/DVD/USB and see if the freezing still happens. – Terrance Sep 23 '18 at 14:15
  • Another thing to try maybe is to disable power saving functions and see. Like maybe turning off ACPI askubuntu.com/questions/160036/… or things like that. – Terrance Sep 23 '18 at 14:18
  • As far as I know, I don't have any screensavers installed that wouldn't have come packaged in Ubuntu or Cinnamon. I've already got all power saving options turned off that I can turn off from regular system settings, but I'll try that ACPI fix too and see what it does. – RevMungo Sep 23 '18 at 14:37
2

I am crossposing my answer from another similar question here:

I had a similar issue on my system. It would lock up on idle when I left the PC alone for a while. It seems to be a known bug with the C6 deep idle power state on AMD Zen processors.

I created a service that disables this power state on boot and it has been running without issue for a few weeks on my system now, so I uploaded it to OBS for others to use. To install it:

$ wget -nv -O - https://download.opensuse.org/repositories/home:jkist/xUbuntu_18.04/Release.key | sudo apt-key add -
$ sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/jkist/xUbuntu_18.04/ /' > /etc/apt/sources.list.d/home:jkist.list"
$ sudo apt-get update
$ sudo apt-get install amd-disable-c6

Versions for other distributions can be found here

Alternatively, you could try to disable the C6 state in your BIOS. If your BIOS is as crappy as mine, though, you might not have that option or you might have to disable all power saving modes instead of just disabling the C6 state.

  • Both upvoted. ;-) – Fabby Dec 21 '18 at 12:25
  • Did not worked, got error: Failed to start Service to disable the C6 State on AMD Zen-based (Ryzen, Epyc) processors on boot. – Tejaskumar Tank Oct 4 '19 at 7:22
  • I noticed the tool failing on other distributions recently, as well. The reason was that msr was not enabled by default. See the troubleshooting section on GitHub. TL;DR: sudo modprobe msr && sudo sh -c "echo msr > /etc/modules-load.d/msr.conf" – tumbleweed_user Oct 5 '19 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.