1

Followup question to:

  1. How can I detect a duplicate version of Lubuntu installed?
  2. How do I remove duplicate versions of Lubuntu? (Followup)

The past couple days I have only specifically been using the 0-34 Advanced Options / Recovery Mode / Resume Normal Boot to log in, because otherwise I get locked forever in a black screen.

It's a solution I basically stumbled upon because I had tried running recovery options (and initially thought that was what helped) but one time in frustration I did 'resume normal boot' and even without running any of the recover options, it still succeeded in getting me in.

The success might have something to do with the warning I get when using Resume Normal Boot:

  • some graphics drivers require a full graphical boot and so will fail when resuming from recovery

It might be the failure of a graphics driver which is saving me and letting me access the OS, if a malfunctioning driver is causing the black screen?

If I can't figure out what is causing the black screen I'd like to change the default option to Advanced > Recovery Mode to save some time until I can diagnose and correct it.


Sept 26 Update: I consulted My computer boots to a black screen, what options do I have to fix it? as David Foerster suggested.

Black/purple screen after you boot Ubuntu for the first time

This usually happens because you have an Nvidia or AMD graphics card, or a laptop with Optimus or switchable/hybrid graphics, and Ubuntu does not have the proprietary drivers installed to allow it to work with these. The solution is to boot Ubuntu once in nomodeset mode (your screen may look weird) to bypass the black screen, download and install the drivers, and then reboot to fix it for ever.

I believe this temporary "nomodeset" fix may be similar to what I've been doing with Recovery/Resume. This answer directs me to read How do I install additional drivers?

23 April 2014 Braim replied "to complete the already excellent accepted answer" with an image pertaining to Lubuntu specifics: https://i.stack.imgur.com/Buo87.png It says to open "System Tools" but then something called "Additional Drivers" under it. That does not display for me so I think it may have been removed from the current version.

Braim notes "after selecting Additional Drivers (or Hardware Drivers in 10.04)" but "Hardware Drivers" doesn't appear under System Tools for me either. I'm not sure what the name of the present equivalent would be for these. I did a search for both HD and AD in Synaptic Package manager couldn't find them.


Nov 11 Update, output of the terminal command lspci -nnk | awk -v n='[0300]' 'p&&/^\S/{p=0}!p{p=index($0,n)}p' requested by David Foerster 01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G72 [GeForce 7350 LE] [10de:01d0] (rev a1) Subsystem: Micro-Star International Co., Ltd. [MSI] G72 [GeForce 7350 LE] [1462:0563] Kernel modules: nvidiafb, nouveau 02:00.0 Multimedia video controller [0400]: Conexant Systems, Inc. CX23418 Single-Chip MPEG-2 Encoder with Integrated Analog Video/Broadcast Audio Decoder [14f1:5b7a] Subsystem: Hauppauge computer works Inc. CX23418 Single-Chip MPEG-2 Encoder with Integrated Analog Video/Broadcast Audio Decoder [0070:7400] Kernel driver in use: cx18 Kernel modules: cx18 02:01.0 FireWire (IEEE 1394) [0c00]: LSI Corporation FW322/323 [TrueFire] 1394a Controller [11c1:5811] (rev 70) Subsystem: Hewlett-Packard Company FW322/323 [TrueFire] 1394a Controller [103c:2a56] Kernel driver in use: firewire_ohci Kernel modules: firewire_ohci 02:04.0 Communication controller [0780]: Conexant Systems, Inc. HSF 56k Data/Fax Modem [14f1:2f20] Subsystem: Conexant Systems, Inc. Soft Data Fax Modem with SmartCP [14f1:200c]

Sorry for delay, system wasn't connecting to internet for a few weeks, now am getting spotty reception and 2 tracker icons, not sure why, may do a sep Q about it if it persists.

I also wrote down what I can see on my monitor type if that is important: Samson Type GH22WS model 226 BW S model code LS22MEWSFV/XAA

Still does the analog/digital swapping forever in normal mode so I'm still booting using the Recovery/Resume trick.

  • 1
    documented what I tried, if the solution's to install graphics drivers I'm not sure how to detect what I need – VistaRefugee Sep 26 '18 at 4:36
  • @VistaRefugee The information that you added to your question is sufficient to explain how to install the proprietary graphics driver in Lubuntu 18.04. Lubuntu 18.04 is bundled with a tool named ubuntu-drivers-common which detects and installs additional Lubuntu driver packages. – karel Sep 26 '18 at 6:30
  • Could you please edit your question to include the output of the terminal command lspci -nnk | awk -v n='[0300]' 'p&&/^\S/{p=0}!p{p=index($0,n)}p'? That way we can see what graphics adapters are available and which drivers they use currently. Thanks. – David Foerster Sep 26 '18 at 13:49
  • I've added the output, sorry for the delay in response. – VistaRefugee Nov 10 '18 at 22:56
1
  1. From where Lubuntu 18.04 is stopped at a black screen open a text-only console by using the keyboard shortcut Ctrl+Alt+F3.

  2. At the login: prompt type your username and press Enter.

  3. At the Password: prompt type your user password and press Enter.

  4. Now you are logged in to a text-only virtual console, and you can run terminal commands from the console. To reboot the system from the console run the command: sudo reboot. In 18.04 press the keyboard shortcut Ctrl+Alt+F2 to exit from the virtual console.

Lubuntu 18.04 is bundled with a tool named ubuntu-drivers-common which detects and installs additional Lubuntu driver packages. The proprietary graphics driver can be installed from the virtual console with the following commands:

sudo ubuntu-drivers autoinstall  
sudo reboot  

The ubuntu-drivers autoinstall command installs drivers that are appropriate for automatic installation including their dependencies, and the proprietary graphics driver will also be updated automatically when an update is available.

When installing a proprietary graphics driver, it is not necessary to uninstall the open source graphics driver. The two graphics drivers can be installed alongside each other allowing the open source graphics driver to be used as a fallback alternative in case there is a problem using the proprietary graphics driver.


If this doesn't work you can possibly get past the black screen where you are stuck by booting with the nomodeset kernel boot option. Instructions for booting with the nomodeset kernel boot option are in the nomodeset tag wiki.

nomodeset kernel option

  • It seems to be booting up now, perhaps faster, or perhaps I was impatient before. Is there a way to get a % complete estimate, or some kind of text display on startup, just so I know the computer hasn't frozen and is doing startup? I never want to see a black screen... – VistaRefugee Oct 30 '18 at 14:34
  • How do I enable verbose mode at boot? It's another kernel boot option that is added like nomodeset. – karel Oct 30 '18 at 14:48
  • Verbose mode sounds attractive, I assume natty means the default boot process. As Demis Palma wrote I changed /etc/default/grub to remove splash_quiet but when I tried to save the changes it said "already exists, overwrite?" then "can't open file to write" – VistaRefugee Nov 10 '18 at 22:50
  • @VistaRefugee Preface each command with sudo to run it as root. Examples: sudo nano /etc/default/grub and sudo update-grub – karel Nov 10 '18 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.