0

I have the Nvidia MX 150 graphics card in my Asus S15 Vivobook running Kubuntu 18.04.

After I install the Nvidia graphics driver, everything runs great except that the system does not wake up after sleep. I have tried multiple versions of the driver, from 340 up to 390, but none of these fixes the problem. I have tried all the fixes I have found on different sites, like updating grub, updating the kernel, and a few other hacks. Unfortunately nothing works. Maybe it's an issue with my MX150 graphics card.

1

Updating to Kubuntu 18.10 fixed the issue

0

You could try this:

Suspend/Hibernation If you use an old NVIDIA driver, hibernation and/or suspend may not work. Here is a potential work around:

We need to edit xorg.conf, open a terminal and enter the following command:

gksudo gedit /etc/X11/xorg.conf In the section called Section "Device" add Option "NvAGP" "1", you should end up with something like this:

Section "Device" Identifier "my id" Driver "my dr" VendorName "my vendor" BoardName "my board name" Option "NvAGP" "1"

EndSection Blacklist the intel_agp module from being loaded by the kernel. This is done by editing blacklist.conf, open a terminal and type:

gksudo gedit /etc/modprobe.d/blacklist.conf Then add the following line:

blacklist intel_agp Reboot your system.

See: https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia?action=show&redirect=NvidiaLaptopBinaryDriverSuspend#Suspend.2BAC8-Hibernation

  • Didn't get a chance to try this. Updating to kubuntu 18.10 fixed my problem. Thanks anyways. – Dr. Lector Jan 21 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.