2

Upon booting Ubuntu 18 tor does not start correctly and gives the error message

 [warn] /var/lib/tor is not owned by this user (root, 0) but by debian-tor (122). Perhaps you are running Tor as the wrong user?

in the syslog. I have specified User=debian-tor in both

/etc/systemd/system/multi-user.target.wants/tor.service 

and

/etc/systemd/system/tor.service.d/override.conf 

but this does not help. I cannot find any more configuration files that specify the user. Can the problem come from the fact that I also have the Tor browser installed?

-1

I don't believe it's an interference with the browser.

I have just installed Tor on my raspberry pi with the latest software and I am experiencing the same problem.

I believe there is a bug somewhere... P.S. I have "Tor version 0.2.9.15 (git-2dc1a1a2abab5403)"

| improve this answer | |
-1

I think I have it working: I changed the permissions to the folder chmod 02700 sshd to have it like this:

root@raspberrypi:/var/lib/tor# ls -lai
...
129841 drwx--S---  2 debian-tor debian-tor    4096 Oct 24 18:28 sshd

and I added in the file "/lib/systemd/system/tor.service" the string "User=debian-tor" as you did.

I disabled and re-enabled the service (sudo update-rc.d tor disable/enable) and it now seem to work

P.S. it always starts-up as root, then after a couple of minutes it changes user.

| improve this answer | |
  • That is a very nasty hack with the set group id. – ctrl-alt-delor Aug 23 '19 at 8:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.