If I have a string like "8383838" and I want just the digits part I can double click to get "8383838" but if I click randomly I sometimes get 8383838 without quotes. I'd like to know what I'm doing to get that, but can't quite figure out how to reproduce it.

1 Answer 1


The behavior I've noted is that the " characters act as a boundary and are not included when double-clicking for a selection (though they are included when triple-clicking to grab the whole line) - I'm using stock settings.

In any case, (as you'd expect) you can change this behavior. From Can I specify what characters set the double-click selection boundary in GNOME Terminal?:

  1. In Terminal, go to Edit > Profile Preferences > General
  2. Remove the " character from the Select-by-word characters box if you'd like to ensure it's considered part of double-click selections or ensure it appears if you'd prefer to treat it as a boundary
  3. Save settings and test to confirm working
  • Ah interesting, I'm actually using urxvt (xterm-like) which is perhaps the place to look. I checked the standard terminal (I'm in ubuntu 18.04) and "select-by-word" wasn't there but since I asked this a while ago, perhaps it's changed. Thanks Gray! Nov 28, 2018 at 19:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .