2

I have a question that I cannot really find an answer to even though many people talked about it. This is my current situation:

  • Using Ubuntu 18.04
  • Using a laptop, which means I cannot just take out my GPU or something
  • Using Nvidia proprietary drivers (version makes no difference for lag, tried every type of installing and blocking nouveau)
  • Using modeset to enable vsync
  • swappiness heavily reduced
  • still not getting a smooth experience

These are my specs:

  • NVIDIA GTX 960M 2GB
  • i7 6700HQ
  • 8GB DDR4 RAM
  • 256GB SSD

These specs should be PLENTY to just have a smooth desktop environment.

Now to make it clear what I am looking for:

  • I want a smooth DESKTOP ENVIRONMENT experience and preferably without switching to something other than Gnome
  • I am NOT looking for smooth gaming. I'll use Windows for that so I don't care about the performance there

Is there anyone here that can help me? Like I mentioned above, I tried all sorts of driver installing and using different types as well. Maybe it's worth mentioning that I had to change the grub as well to even get it to show the login screen after installation.

Honestly hoping that someone can finally help me solve this. If there is a way to disable the GPU entirely and switch to my Intel HD Graphics and that would solve it, that is fine as well. Didn't find any way to do that yet though.

2

Besides your graphics card and different Ubuntu version, my specs are all older than yours. Ubuntu runs much smoother for me than Windows 10. I think it be worth a shot to reinstall a fresh image and try what's below.

sudo apt-add-repository ppa:graphics-drivers/ppa

sudo apt update

sudo apt install nvidia-driver-390

Add nouveau.modeset=0 to GRUB to allow Ubuntu to boot up normally without affecting drivers.

In terminal, type

sudo nano /etc/default/grub

And replace the line that begins with GRUB_CMDLINE_LINUX_DEFAULT= to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0"

Hit CTRL+O to write it out, enter to save it, then CTRL+X to exit. Then update GRUB: sudo update-grub

If that still doesn't help you can try posting your syslog and maybe someone more experienced can help. I looked at mine and it turns out there was an issue with theh touchpad that's solvable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.