2

After a clean installation of Ubuntu 18.04, I realize that the sleep mode does not work. When I suspend from the menu button or with the sudo pm-suspend command, the screen turns off but the power LED stays on and the fan continues to run. In addition, no keyboard keys or even the power button wake the computer. The only solution is to force the shutdown by pressing the power button.

After reading different posts, I did not find a solution to my problem.

  • I do not have a nvidia graphics card.
  • The command cat /sys/power/mem_sleep tells me that I'm in deep mode (s2idle shallow [deep])
  • I tried different kernel versions: 4.18.7, 4.17.14 and 4.15.0-34(=current)

Computer specifications: Samsung NP530U3B with ubuntu 18.04 64bit. It's a core i5 with 4Gb of ram and no graphic card.

Hope you can help me.

Regards,

Marchand D.

  • Hi, I am getting the exact same problem in a Dell Inspiron 7373, did you find a solution for this? – Cesar Jul 2 at 22:37
1

My boss and I had similar issues with our Dell Venue 11 Pro 7140. After many releases, Dell eventually discovered an S3 bug relating to pre-5.0 kernels. They advised 2 things:

  1. Update the BIOS to the latest version available, most likely post-November 2018.

  2. Upgrade to a 5.0 kernel.

Additionally, we found 2 more things were required:

  1. Completely clean your user config (as in, mv ~/.config ~/.config.old) as some previous settings in X11 have hung around in upgrade and are incompatible with S3 "freeze" features.

  2. a. If using Gnome, change Settings->Power->"When the power button is pressed" from "Nothing" to "Suspend".

    b. If using XFCE, change all "freeze" settings to "suspend" in the Power Manager.

0

I had a similar issue where suspend would shutdown my machine, but I could not restart it without a hard reboot on the PSU. I resolved it by installing one package:

sudo apt install uswsusp

I verified this worked by suspending from the terminal:

sudo systemctl suspend

  • Hello yellowjacket05, Thank you for your help unfortunately the installation of the package does not change anything. I waited 5 minutes to be sure but the power led stays on and the fan continues to turn... – Daniel Marchand Feb 1 at 13:25
-1
sudo systemctl suspend -i

[ edited to -i as I incorrectly put in -l previously]

and I need to unplug all usb ports before doing so else they are lost. it is, however, unreliable as said above.

also last night it was as you say yours is, blank screen fan running and did not go to sleep until I pressed the space bar. go figure.

  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Dr_Bunsen Jul 4 at 12:46
  • It does for me, without that -i in a terminal I get the following error message."Operation inhibited by "....... reason is "user session inhibited". Please retry operation after closing inhibitors and logging out other users. Alternatively, ignore inhibitors and users with 'systemctl suspend -i'. " – pierrely Jul 5 at 5:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.