3

I'm on Ubuntu 18.04. To install Avro I first downloaded the latest version(avro_2.1-3_all.deb) from github using command

$ wget "https://github.com/ugcoder/avro/releases/download/v2.1/avro_2.1-3_all.deb"

Then installed:

$ sudo dpkg -i avro_2.1-3_all.deb

Then finally ran these command:

$ sudo apt-get install -fy
$ ibus restart

Before these download and installation, I entered "Language Support" and ensured that the box for Bangla is ticked in "Installed language". Also ensured that Keyboard input method id IBus.

Now once avro is installed, I went to settings and added Bengali(Avro Phonetic)" as input source.

Now I opened LibreOffice Writer switched to Avro using super+space. Everything was set, only all that is coming are English letters. Same happened on gedit, same happening now: I wrote this whole question with Avro selected!

What's happening?

To enquire, I checked to keyboard layout of Avro Phonetic. Surprisingly avro's keyboard layout is identical to English(US)! I then manually downloaded the avro fonts and copied them to /usr/share/fonts/truetype and restarted my PC. The result is same. Now what can I do to write Bangla with Avro?

  • 1
    I followed this link to to install avro: askubuntu.com/questions/1035875/installing-avro-in-18-04-lts – Anik Samiur Rahman Sep 22 '18 at 6:20
  • Update: I've removed Avro 2.1-3 using "$ sudo apt-get purge avro" then reinstalled Avro 2.0-1 following the installation procedure given in avro github page. The result is same, I still can't write Bangla with Avro! – Anik Samiur Rahman Sep 22 '18 at 6:30
  • Is ibus showing up in the notification menu? Does the icon change to avro icon when you press super+space? Are you sure that the shortcut for toggling is super+ space? Check ibus settings – Archisman Panigrahi Sep 22 '18 at 6:55
  • Archisman Panigrahi: Yes, Avro appears in notification menu when I press super+space. I used avro before in this PC. For a reason I had to reinstall Ubuntu 18.04. It worked perfectly in the previous installation. Dunno why now its causing problem. – Anik Samiur Rahman Sep 22 '18 at 7:22
  • Have you selected the Keyboard input method system to "ibus"? – hmhsl Nov 1 '18 at 22:14
2

try this command and then restart ibus. Restart your PC if needed.

rm ~/.candidate-selections.json
ibus restart
1

I faced the same thing. In my case, I uninstalled Bangla from Language input source. Unistalled Avro too. Then Reinstalled Avro from here. Then do the things stated below.

Just click on Bangla(Bangladesh) Like this Image and a new window will come.

Select Avro Phonetic from there. Like this one I think it will fix the thing!

1

You may have run into a bug, which now has been fixed.

Avro Phonetic has recently been made available to Ubuntu users via an official package, which includes that bugfix.

To install it:

sudo apt install ibus-avro

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.