0

I have been trying to set a shortcut for changing between input languages and at some point a window popped up that asked me to set that shortcut. After that whenever I use that key to toggle it only changes from English to my local language and doesn't change back to English if I pressed it again. I think something went wrong during the download and install of adding the second language and setting a shortcut for it. Is there a way to download and reinstall these settings all over again?

Edit: Running the snippet cat /etc/default/keyboard outputs:
XKBLAYOUT=us,ir
BACKSPACE=guess
XKBVARIANT=,pes_keypad

  • 1
    What shortcut key are you trying to set? – vanadium Sep 22 '18 at 6:30
  • I have set right alt key. – Friendly Fella Sep 22 '18 at 10:51
  • Please edit your question and show us what the command cat /etc/default/keyboard outputs. – Gunnar Hjalmarsson Sep 22 '18 at 15:01
  • @GunnarHjalmarsson Done. – Friendly Fella Sep 23 '18 at 12:48
  • That file does not include any option for switching keyboard layout. What kind of desktop environment are you on? Ubuntu with Unity or some flavor? – Gunnar Hjalmarsson Sep 23 '18 at 16:51
0

The point that I had missing was that by default you could have switched between input languages by using the combination Super+Space; but if you somehow did something that ruined this shortcut, you can run the command gsettings reset org.gnome.desktop.input-sources xkb-options to erase the new settings and it's now back to default. If you want to use any new combination you can set it through the settings menu.

All credits go to @GunnarHjalmarsson for helping me out through this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.