1

I have not been able to get the current workspace number permanently on the desktop. If I press the window key, of course I can get it, but find this annoying. I have 4 fixed workspaces, set by gnome-tweaks. I note that Fedora 28 Gnome has the workspace number on the status line ( showing 2/4 to indicate workspace 2 of 4).

  • correction: "I have 4 fixed windows" should be 4 fixed workspaces. – DougT Sep 21 '18 at 15:06
  • 1
    Rather than commenting on your own question, you can click the edit button below it and revise it – WinEunuuchs2Unix Sep 21 '18 at 15:12
3

Install the following gnome extension:

workspace-indicator

enter image description here

Or install from Ubuntu package with the default Gnome Shell extensions - it's probably more reliable.

You can install it using:

sudo apt install gnome-shell-extensions

After installing that package, restart Gnome Shell using Alt+F2 and typing r, then press the Enter key.
And finally enable the "Workspace Indicator" extension using Gnome Tweaks.

  • Not sure what extension fedora uses, where according to the OP it apparently shows "1/4", etc. on the status line (aka top bar?) – vanadium Sep 21 '18 at 16:14
  • 1
    I'd recommend using the Ubuntu package with the default Gnome Shell extensions - it's probably more reliable. You can install it using: "sudo apt install gnome-shell-extensions". After installing that package, restart Gnome Shell using Alt + F2 and typing "r" (without the quotes), then press the Enter key. And finally enable the "Workspace Indicator" extension using Gnome Tweaks. – Logix Sep 21 '18 at 17:31
  • Logix and abu_bua: Your procedure worked (others I tried did not). Thanks. – DougT Sep 22 '18 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.