0

I found myself needing a text editor that would handle a large (44Mb) XML file happily. I ran across CudaText (licensed under Mozilla Public License 2.0), a newish cross-platform text editor that has been well reviewed.

With apt search cudatext, I found it was available to install via sudo apt install, and did so. (It's also available in the Ubuntu Software "app store".) It did indeed handle my large XML file without breaking a sweat, and I got my editing done...

...but it wasn't easy, for an odd reason. It seemed to capture/record only occasional keystrokes, although I managed to get my edits done using copy/paste and using another text editor to create the strings needed.

I posted this as an issue in the dev's Github repo, and he cannot replicate my experience. Here's what I posted (slightly re-formatted, and now updated):

For some reason, I cannot type text into the editor. It doesn't matter whether the file is "new", or whether I open an existing file for editing. The size doesn't matter. The same thing happens in the other "fields" that take user input (e.g., "find", or "command palette" filter).

If I'm in the main editing window, it seems like when I type FAST, I have a better chance of the keystroke being recognized, but if I type at a normal rate, only the rare keystroke is recorded/echoed, nor are they saved if the file is saved -- i.e., it is not an issue about displaying to the screen, but the keystroke actually being recorded. The arrow keys don't work at all to position the cursor.

There are two exceptions to this erratic input behaviour:

  1. striking the Enter key always is recognized, as is the Backspace key, UNLESS I use the arrow keys to position the cursor (which disappears): then neither Enter nor Backspace work, until I use a mouse-click to position the cursor explicitly -- then both are back to normal; and
  2. if I paste text (after Ctrl-C from a different app), then it is recognized and inputs correctly. This is how I managed to edit my large XML file successfully (I typed my string into a different text editor, copied, then pasted it into the CudaText window).

I have searched this issue list, and can't find anyone else having the problem. I saw the "opposite" problem in #855 and checked my input method. I'm using IBus (not XIM), but even setting my input method to "none" made no difference to CudaText.

I thought I would see if any AskUbuntu types have had this experience? Or any suggestions for coaxing it into behaving properly? It seems like a helpful tool, but frustrating if it doesn't accept input properly.

I'm on Ubuntu 18.04 LTS.

1

Just in case anyone else gets hit with this: the issue did indeed appear to be with having xim as the system's input method.

I struggled to get my "input method" to none but ... my system changes seem now to have "stuck". At first, it kept coming up xim no matter what I did. But now my system settings show "none" for "input method", and I get this when checking in terminal:

$ im-config -m
default
none
ibus

ibus

And CudaText is now accepting input perfectly. I'm not sure why I had such a hard time with this, but it's good to know that this configuration fixes the issue I had.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.