1

I have a Canon LBP2900 printer. Whenever I try to print something, Ubuntu gives me a notification that it is printing, and then says it has finished printing, but nothing is actually printed. I have tried many suggested fixes but nothing works. Can someone provide a step by step solution?

1 Answer 1

0

you need the CAPT driver; please see my answer in the this thread

Install Canon 2900 driver in Ubuntu 16.04

this assumes the 2900 is the only usb printer connected to your computer

1
  • Thanks ,for answering .I have tried your solution and the printer still refuse to print. Maybe installing and trying many solutions is tolling up and causing problems.I was wondering if it's possible to reset everything and start from point zero ,or do you have any other solution.......By the way i looked at the printer option and the state is.....Idle - ccp send_data error, exit does that means anything. Sep 21, 2018 at 6:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.