I'm using Ubuntu 18.04, installed it on a clean HDD 5 days ago. I've just plugged in my Wacom tablet - which is Wacom Bamboo CTL-470, and it worked instantly - stylus moves the mouse around, applications can read pressure, and stylus's touching and both buttons are mapped to left, middle and right mouse button.

In system settings>Devices>Wacom Tablet, "Tablet" page works, but "Stylus" page doesn't - it says "No stylus found" no matter what - and yes, I did hover my stylus over the tablet - even tried holding it above the tablet while rebooting, and on bootup it still didn't find it.

I'd like to rebind one of the buttons to CTRL+Z, but with it not detecting the stylus it doesn't want to show me the settings.

Any attempts to look up this problem on the internet resulted only in me finding solutions for the problem when that tablet doesn't work completely, and for older versions of Ubuntu.

  • 1
    welcome to AskUbuntu! you might need to use GnomeTweaks... sudo apt install gnome-tweaks then run gnome-tweaks and see if you can see your stylus there.... – Joshua Besneatte Sep 20 '18 at 16:12
  • No, I can't. I navigated through all of the menus with the stylus, and there was nothing related to the tablet or stylus anywhere. – Architector 4 Sep 20 '18 at 16:24
  • did you try the instructions here: help.ubuntu.com/stable/ubuntu-help/wacom-stylus.html.en – Joshua Besneatte Sep 20 '18 at 16:27
  • Pressing on "Wacom Tablet" just redirects to that same page in Settings, and those buttons are not available since it doesn't see the stylus. – Architector 4 Sep 20 '18 at 16:36
  • I have similar behaviour with a Thinkpad L390 Yoga running Ubuntu 19.04. The pen works but in Settings -> Devices -> Wacom Tablet, it says "no stylus found". Running "xsetwacom --list" returns "Wacom Pen and multitouch sensor Pen stylus....". – daveraja Oct 9 '19 at 21:38

I found an alternative way of configuring stylus buttons if Ubuntu settings refuse to show the settings. The way is described here, in the "Wacom tablet" section on Ubuntu 16.04 for my digital painting workstation - David Revoy:

In Cinnamon, the GUI for Wacom tablet offer minimal yet powerful set of options: set buttons, set proportions to the screen...etc... The GUI is limited because you can't assign buttons modifier like , and ...

Xsetwacom: For those who really need a way to assign this key and do more, here is the (big) workaround involving command line, script and other dirty things a normal user shoudn't consider as something normal to setup an hardware (graphist needs a GUI and focus on making good graphism, not script/code):

1. Get your tablet device name:

xsetwacom --list

This command returns the name of my Wacom device, useful for my script:

Wacom Intuos3 9x12 Pen stylus    id: 11 type: STYLUS
Wacom Intuos3 9x12 Pad pad       id: 12 type: PAD
Wacom Intuos3 9x12 Pen eraser    id: 15 type: ERASER
Wacom Intuos3 9x12 Pen cursor    id: 16 type: CURSOR 

Note for reference your tablet pad name, mine here is Wacom Intuos3 9x12 Pad pad in this example. Select the name, then press ++C to copy it in your terminal.

2. Create a Xsetwacom bash script Open the file manager (Nemo) , and in the folder of your choice ( I use /home/deevad/Script on my installation ) create a new empty file with right-click , "create a new document">"Empty document". Name it tablet.sh , then open it with a text-editor (Gedit). Inside it write a script like this with your tablet name:

#! /bin/bash
xsetwacom set "Wacom Intuos3 9x12 Pad pad" Button 1 "key Shift_L"
xsetwacom set "Wacom Intuos3 9x12 Pad pad" Button 2 "key Control_L"

This example script will map to the button 1 of your tablet (resize brush in Krita) , and Control to the button 2 ( pick color on Krita/Gimp/Mypaint) of the tablet. The special keys use standard names, for assigning other type of key I paste here a list : http://pastebin.com/aXGDkJTU

If you want to assign a modifier ( eg. Ctrl ) on the stylus button, it's also possible:

xsetwacom set "Wacom Intuos3 9x12 Pen stylus" Button 2 "key ctrl"

You can test all your xsetwacom lines inside the Terminal before writing them in your script. This way you'll test if you have a Button 5 , or Button 20... etc... For my Intuos 3, the layout of the right side is like this ( I found it with guessing and trying ):

# ---------
# |   | 1 |
# | 3 |---|
# |   | 2 |
# |-------|
# |   8   |
# ---------

When your script is finished you can save it. In the file-manager ; right-click on it again > Properties > Permissions > and in front of Execute check the box for 'Allow executing file as a program'.

3. Run it, create a start-up You can double click and run the script. Your key on tablet will be mapped. But all setup of the button will not last a reboot. That's why we made a script to execute it at each start-up. Go now on 'System Settings', then 'Start-up application' , press the 'Add' button , give the form a name of your choice, for the command pick your script via the 'Browse' button, and comment what you want about it.

More informations about Xsetwacom: http://linuxwacom.sourceforge.net/wiki/index.php/Xsetwacom


Check if you have xf86-input-wacom installed, if not install it and restart Xserver or reboot.

In my case, I had the kernel driver and libwacom installed but not xf86-input-wacom; and, I suffered of the same symptoms, though I'm using Arch and not Ubuntu.


To get the stylus to work I grabbed an up-to-date version of the libwacom.stylus file and replaced the old version at /usr/share/libwacom/libwacom.stylus

You can find the up-to-date libwacom.stylus files on the Github: https://github.com/linuxwacom/libwacom/tree/master/data

  • @josh.chavenne In my case after doing this my ubuntu did not boot any more. – ubuntuuser Jan 30 at 13:47
  • I'm pretty sure that wouldn't keep your system from booting, and not sure whats up with the downvote - but good luck. – josh.chavanne Mar 4 at 18:52
  • @josh.chavenne I am aware that this is not understandable. But after booting in protected mode an undoing (removing the file) the system woked fine again. After all at the moment Wacom intuos definitely does not run properly in ubuntu 18.04. – ubuntuuser Mar 6 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.