19

I have installed Ubuntu 18.04 on my mid-2009 MacBook Pro, however, I am unable to even search for a wireless internet connection.

I have searched past question from this site and askubuntu re; no wi-fi adapter found, and found they either refer to past versions of Ubuntu or their implementation strategies (e.g. sudo update) does not to MacBooks or don’t work because they rely on internet connection that I do not have (e.g. sudo...reinstall kernel source).

11
  • 1
    Welcome to AskUbuntu! Is using ethernet and option? can you please post the output of sudo lshw -class network to your question? Sep 20, 2018 at 16:00
  • I suppose your Ubuntu desktop environment is Gnome. Could you open a terminal and run the following command: inxi -c 5 -b and post the output?. Also you can search in hardware section whether your wifi card requires to install the wifi proprietary hardware. Sep 20, 2018 at 16:00
  • I am getting an command not found I when I type in the code. Excuse my ignorance but would the hardware section be located in the about section?
    – Nmanny
    Sep 20, 2018 at 16:07
  • I am not currently able to upload a photo as I am using my phone (zero laptop internet connect). I have typed what you suggested in the terminal and have the results and able to select useful info
    – Nmanny
    Sep 20, 2018 at 16:12
  • can you take a photo with your phone and upload that? or type in the product and vendor information? can you connect the lappy via ethernet? Sep 20, 2018 at 16:15

6 Answers 6

25

I think I have the exact same hardware (13 inches?) and OS installed, and I too had problems with my wifi card. The easiest workaround is to have an Ethernet connection while you install Ubuntu and check the "install proprietary drivers", but I guess it's too late for that one.

Still, you will need an internet connection through Ethernet to solve this, as you have to download and install the drivers.

If you open "Software & Updates" and go to the "Additional Drivers" tab, what do you see? It should look similar to my screenshot.

enter image description here

Make sure "Using Broadcom 802.11 ..." is selected, probably it says "Do not use this device". Once you click the other radio button and then hit apply, it should download and install the driver.

5
  • Here's your long time overdue credit; this solution worked perfectly for me.
    – Minty
    Dec 22, 2018 at 23:16
  • Worked for me in 20.04.
    – tuomassalo
    May 13, 2020 at 12:32
  • I have 19.3 Mint here, the wifi and nic drivers would not install via driver-manager, UNTIL I had an external wifi plugged in and working. After that, the drivers would install via the exact same menu (driver-manager). I guess internet is somehow needed.
    – mistige
    May 30, 2020 at 12:41
  • i think you can also use usb tethering instead of ethernet
    – suhailvs
    Jul 14, 2021 at 10:34
  • Worked perfectly for me. Tips: if you don't have access to Ethernet, I used my iPhone with Sharing Connection via Bluetooth, and it works directly. Thanks
    – Henri
    Aug 26, 2021 at 18:41
15

What worked with my late-2008 Macbook Pro and Ubuntu Mate:

  1. Use Ethernet cable
  2. Confirm hardware: lspci -vvnn | grep -A 9 Network -> Broadcom 4322 chipset
  3. Install proprietary driver instead of b43

For some reason, Ubuntu's "Additional Driver" showed 0 option to update from that menu. Thus, I followed the manual update steps described in the documentation, more precisely these commands:

sudo apt-get update
sudo apt-get --reinstall install bcmwl-kernel-source

sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
sudo modprobe wl

After that, without reboot, the network icon started listing the wifi networks and I could join my network.

7
  • 1
    This worked for me on my MacBook 5,2. Thanks!
    – gosukiwi
    Oct 10, 2019 at 18:02
  • Thanks! - This worked perfectly for my Ubuntu 18.04.2 LTS on a MacBook 5,1 (Broadcomm 4322 chipset). Note that the command inxi -F is a really nice replacement for lspci and it shows the driver info (you may have to install it though - sudo apt install inxi) Jan 8, 2020 at 19:56
  • Doesn't work with ubuntu 20.04 . any idea ?
    – Hadley
    May 13, 2020 at 3:12
  • @Hadley did you figure it out? I just followed those directions for my MacBook with 20.04 and it worked just immediately. What Mac do you have? I'd run the sudo lshw -C network and see who made your wireless card.
    – xbakesx
    May 16, 2020 at 20:26
  • @xbakesx , I also followed above guide but no luck. I use mac book pro of late 2013 model
    – Hadley
    May 17, 2020 at 0:53
6

The top answer is the right answer, however, in my experience the download/install gets interrupted, and the command to accomplish this is much more reliable:

sudo ubuntu-drivers autoinstall

1
  • Perhaps you could clarify which answer is the top answer, since they shift around sometimes. I like this one the best, though. Always prefer CLI over GUI. Feels stable and robust. Feb 4, 2020 at 17:27
6

everyone! Interesting topic here...

I wanted to share with some of my experience though. Some computers do not have Ethernet (for example my MacBook Air and HP Z2 Mini Workstation). And after installing Ubuntu the Wi-fi adapter (external USB one in case with Z2) were not visible/usable without respective drivers installed...

So, I found out that my Meizu 15 (Android) phone helped me out. I switched on Internet sharing by USB and appeared immediately as Ethernet connection on both systems, then I was able to install all the drivers that I needed :)

Enjoy and good luck with Ubuntu!

1
  • Thanks for a very helpful advice! Feb 22, 2020 at 3:50
1

I got the same problem on my mac mini. I went into the additional drivers tab as mentioned above and the specific driver was already checked. So I checked the "Do not use the device" and restarted. After rebooting the wireless controller works like a charm.

0

In some situations, including with Ubuntu derivatives (PopOS and/or very similar hardware, the way to handle this is different.

There are three ways to handle the Broadcom cards depending on what you have

This page has a great chart that shows (as of October 2020) which driver you need. It also goes over very specific and detailed steps for what to do to get that driver working, including what to do if you have to download something but can't get online because you don't have a driver for the card.

In short, you:

  • Figure out which card you have: lspci -nn -d 14e4:
  • Follow the instructions for firmware-b43-installer, bcmwl-kernel-source, or a special case.

Not the answer you're looking for? Browse other questions tagged or ask your own question.