0

while I was compiling the kernel it suddenly started giving me these errors

--------------------------------------------------------------------------
drivers/net/wireless/intel/iwlwifi/mvm/tdls.o: file not recognized: File truncated

scripts/Makefile.build:530: recipe for target 'drivers/net/wireless/intel/iwlwifi/mvm/iwlmvm.o' failed

make[6]: *** [drivers/net/wireless/intel/iwlwifi/mvm/iwlmvm.o] Error 1
scripts/Makefile.build:558: recipe for target 'drivers/net/wireless/intel/iwlwifi/mvm' failed

make[5]: *** [drivers/net/wireless/intel/iwlwifi/mvm] Error 2
scripts/Makefile.build:558: recipe for target 'drivers/net/wireless/intel/iwlwifi' failed

make[4]: *** [drivers/net/wireless/intel/iwlwifi] Error 2
scripts/Makefile.build:558: recipe for target 'drivers/net/wireless/intel' failed

make[3]: *** [drivers/net/wireless/intel] Error 2

make[3]: *** Waiting for unfinished jobs....

scripts/Makefile.build:558: recipe for target 'drivers/net/wireless' failed

make[2]: *** [drivers/net/wireless] Error 2

scripts/Makefile.build:558: recipe for target 'drivers/net' failed

make[1]: *** [drivers/net] Error 2

Makefile:1033: recipe for target 'drivers' failed

make: *** [drivers] Error 2

the output of ( sudo lshw -C network ) is

*-network

   description: Ethernet interface

   product: 82540EM Gigabit Ethernet Controller

   vendor: Intel Corporation

   physical id: 3

   bus info: pci@0000:00:03.0

   logical name: enp0s3

   version: 02

   serial: 08:00:27:82:8c:92

   size: 1Gbit/s

   capacity: 1Gbit/s

   width: 32 bits

   clock: 66MHz
   capabilities: pm pcix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=e1000 driverversion=7.3.21-k8-NAPI duplex=full ip=10.0.2.15 latency=64 link=yes mingnt=255 multicast=yes port=twisted pair speed=1Gbit/s
   resources: irq:19 memory:f0000000-f001ffff ioport:d010(size=8)

what should I do

  • 1
    Welcome to Ask Ubuntu! tell me what the kernel and Ubuntu version your have? – abu-ahmed al-khatiri Sep 20 '18 at 15:04
  • the kernel "version is 4.15.0-34-generic" – Ali Hijazi Sep 20 '18 at 15:12
  • the ubuntu version is 18.04.1 – Ali Hijazi Sep 20 '18 at 15:14
  • Why did you feel that you need to compile an older version of iwlwifi than is already included in Ubuntu 18.04? Are you having wireless trouble that we can help you with? Welcome to Ask Ubuntu. – chili555 Sep 20 '18 at 15:19
  • tell me what the output of sudo lshw -C network and edit your question with that output – abu-ahmed al-khatiri Sep 20 '18 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.