1

I downloaded Driver for Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller from their site : http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=7&PFid=7&Level=5&Conn=4&DownTypeID=3&GetDown=false#2

IT is saved in "Downloads" folder

Went through the "readme" which said

Unpack the tarball : # tar vjxf r8101-1.aaa.bb.tar.bz2

Change to the directory: # cd r8101-1.aaa.bb

When I ran the command

tar vjxf r8101-1.033.00.tar.bz2

It gave the following error :

tar (child): r8101-1.033.00.tar.bz2: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now

I then tried to change the directory to "r8101-1.033.00" :

cd r8101-1.033.00

and it gave back :

 bash: cd: r8101-1.033.00: No such file or directory

What am I doing wrong ? how should I do it ?

  • 1
    Did you cd ~/Downloads first? Welcome to Ask Ubuntu. – chili555 Sep 20 '18 at 14:29
  • No i did not, but I manually opened the downloads folder, and ran terminal form there too. Does it makes a difference ? – Spectra Sep 20 '18 at 14:40
  • It certainly does. If the file downloaded to Downloads, then you need to direct the terminal there: cd ~/Downloads It doesn't matter where the file browser GUI is situated. The terminal has no way to know that. – chili555 Sep 20 '18 at 14:55
2

Manually search for the 0010-r8101-1.033.00.tar.bz2 archive (LINUX driver for kernel up to 4.10) and drag this archive's icon into the terminal to show the full path to it. The full path to 0010-r8101-1.033.00.tar.bz2 is everything in the path except for 0010-r8101-1.033.00.tar.bz2 itself which is the archive's correct name.

Change directories using cd to the full path that you previously noted and run this command:

tar vjxf 0010-r8101-1.033.00.tar.bz2 # the archive's correct name is 0010-r8101-1.033.00.tar.bz2

When you have changed directories using cd to the directory containing 0010-r8101-1.033.00.tar.bz2 you can check that you are in the correct directory by running ls. The results of ls should show that 0010-r8101-1.033.00.tar.bz2 is contained in the current working directory, so the command tar vjxf 0010-r8101-1.033.00.tar.bz2 will be successful since 0010-r8101-1.033.00.tar.bz2 is accessible from the current working directory.

When you extract the contents of 0010-r8101-1.033.00.tar.bz2 it extracts them to a directory named r8101-1.033.00 which contains instructions for the next steps in the readme file.

  • Thanks it worked. Actually I omitted 0010 part that you typed in bold, and it still worked. any clue ? – Spectra Sep 20 '18 at 14:48
  • The tar vjxf r8101-1.033.00.tar.bz2 command showed the same error message as in your question when I tried it, but the tar vjxf 0010-r8101-1.033.00.tar.bz2 command worked when I tried it. – karel Sep 20 '18 at 14:51
  • Sorry for the mistake @karel , I typed 0010, but overlooked :/ – Spectra Sep 20 '18 at 14:56
0

From the file I downloaded, your file name is wrong.

After moving in to the directory that you downloaded to, it should be tar vjxf 0010-r8101-1.033.00.tar.bz2

  • Yes, you are right, there is a 0010 before -r8101. but the instruction that realtek gave did not contain that part. so I chose to omit it. – Spectra Sep 20 '18 at 14:45
  • @Spectra - You can't just omit things. If it's in the file you downloaded, you need it in the command. The instructions Realtek gave were for reference. – Lewis Smith Sep 20 '18 at 14:47
  • My bad sorry. But I omitted that part and it worked, I think. I am editing my original post. – Spectra Sep 20 '18 at 14:52
  • @Spectra Don't worry. This is how we learn. Let's start again. Run the following: cd ~/Downloads then tar vjxf 0010-r8101-1.033.00.tar.bz2. Has it extracted the tar? (it will be in a folder named 0010-r8101-1.033.00) – Lewis Smith Sep 20 '18 at 14:53
  • Ummmmmmm....My big big bad...sorry Lewis, actually I typed 0010 and did not see it. :/ – Spectra Sep 20 '18 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.