3

This is common hardware issue in older mouses that they click twice (in rapid succession) even button is pushed once.

In 32bit Ubuntu 16.04.5 LTS LightDM desktop i would like to define minimum delay between clicks in a doubleclick action for the mouse. (so i filter out eroneous doubleclick made in low number miliseconds) In mouse settings there is no setting for this. Or if that is not possible even with any workaround, then how i can disable system-wide doubleclick, so even in apps like a Firefox, when i doubleclick, it will trigger only single click action.


I already tried several things and relogin after it, but none is working:

wget https://aur.archlinux.org/packages/xf/xf86-input-evdev-debounce/xf86-input-evdev-debounce.tar.gz

tar xzf xf86-input-evdev-debounce.tar.gz

patch -p1 < ..xf86-input-evdev-debounce/debounce.patch

---- OR:

echo *multiClickTime: 800 >~/.Xresources

xrdb -merge .Xresources

---- OR:

OpenBox configuration manager in Lubuntu, there is no setting for mouse debounce

---- OR:

Kde uses qt while gnome, firefox, chrome,and others use gtk. System settings in Ubuntu's port of kde only sets the double click inteval for qt. Hence gtk apps are left at 200ms (default).

A workaround for this:

edit ~/.gtkrc-2.0

add gtk-double-click-time = 800 (800 is ms, change as desired)

Restart gtk applications and they should work.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.