0

In 16.04, a right click on 'Files' (Nautilus) in the Unity launcher brought up a list of common places.

In 18.04 there are only 3 options ('New Window', 'Remove from Favourites' and 'Details'), none of them places.

Is it possible to add places to that menu?

Edit: Thank you, Pomsky for pointer to your post. I had already tried that, and did so again. This works fine to step 5. Nautilus opens as expected, but when the mouse hovers over it, it is called 'Files', not 'File Manager' as I'd expect, and when I add it to favourites, the message is 'Files has been added...' Then after step 6 the options I have added do not appear in the menu, only the 3 already there. I know Gnome is finding the right .desktop, because if I remove it, 'File Manger' ceases to appear in 'Activities'

EDIT 2: As Doug has said, I don't believe this is exactly a duplicate. The problem seems to be the numerous nautilus desktop files in /usr/share/applications.

  • Welcome to Ask Ubuntu! Could you please add a little more detail? What exactly did you do (which files did you change and what do they contain now), what did you expect to happen and what happened instead? Did you encounter any warning or error messages? Please reproduce them in their entirety in your question. You can select, copy and paste terminal content and most dialogue messages in Ubuntu. Please edit your post to add information instead of posting a comment. (see How do I ask a good question?) – David Foerster Sep 22 '18 at 13:05
  • This is not a duplicate, those voting try reading the question a little closer.. – doug Sep 22 '18 at 13:43
  • This is not easily done, but possible. Best solution is to 1st copy nautilus.desktop from /usr/share/applications to ~/.local/share/applications. Then remove at least 2 if not all 3 nautilus desktop files in /usr/share/applications. After that you need to edit the copied nautilus.desktop to add wanted locations to the desktop actions. Afterwards add back the icon to the launcher.. Any edits to a .desktop file aren't reflected until a quiting of nautilus or a log out/in, gnome is stupid in this manner in 18.04. Can't show you how as question is 'closed' to answers – doug Sep 22 '18 at 13:49
  • Thank you very much, Doug. That has more or less worked. I have a 'Files' icon on the launcher that does the necessary, but I can't get rid of the original. 'Remove from favourites' won't work. I have deleted 3 varieties of nautilus desktop from /usr/share/applications. There are possibly more (nautilus-classic.desktop and nautilus-home.desktop, org.gnome.Nautilus.desktop). What on earth do they all do? – Pansmanser Sep 23 '18 at 14:11