14

I need to extract the content of a Nero .NRG image. What can I use since I do not want to burn it.

  • sudo mount -t iso9660 yourfile.nrg /mnt/ – Michał Rugbuś Mar 28 '16 at 14:41
  • 2
    NRG is not an ISO format. – Luis Alvarado Mar 28 '16 at 14:57
19

You can convert it to iso via nrg2iso

sudo apt-get install nrg2iso
nrg2iso source.nrg desitination.iso

or you can try nero for linux

  • At least it helps in extracting afterwards the information. Thanks Aboobacker. – Luis Alvarado Feb 25 '12 at 16:02
  • Just to add. To use it it is easy: nrg2iso IMAGE.nrg IMAGE.iso. – Luis Alvarado Feb 25 '12 at 16:05
  • i'm using ubuntu 12.04 too, but it doesn't work for me. when use this command, says: It seems that SOURCE.nrg is already an ISO 9660 image‍‍‍‍‍‍‍‍ [Aborting conversion] I'm sure it's .nrg file because i get it from nero in Windows7 – Netmoon Oct 9 '12 at 8:04
  • @Netmoon: try to rename the file to filename.iso and extract it – Tachyons Oct 9 '12 at 8:59
  • Unfortunately nowadays nrg2iso does not work - converted iso image is empty when mounted via mount and makes Virtualbox display and error. Still looking for another solution. Perhaps my NRG images are too new for the tool? – Pawel Debski Mar 31 '18 at 21:36
3

One solution is to convert NRG to ISO using nrg2iso program. Another solution is to mount NRG using acetoneiso2. Both programs are present in repositories.

  • I first tried acetoneiso2 but it gave me an error for the nrg file. I used it first because it said that it supported nrg files. In any case I have just converted the nrg to iso. Thanks for the suggestion sindikat. – Luis Alvarado Feb 25 '12 at 16:04
3

Furius ISO Mount could mount or burn .nrg Images

It is in the Software Center

2

I have a number of nrg images that I need to either mount in Ubuntu or have mounted by guest machines in Virtualbox.

Current version of nrg2iso is 4.4 from 2004 and it was not able to convert these images to iso properly - resulting image was either empty or caused Virtualbox to display errors.

After reviewing different options I installed gCDEmu - the most acclaimed software for mounting CD images. Now I have image mounted and readable.

Unfortunately Virtualbox is not able to attach guest machine's virtual CD to the virtual one created by CDEmu. Therefore I used Brasero to copy CD to image to create iso file. This way I am able to mount the image directly in Virtualbox.

As iso format does not have any built-in checks I have also created hash sums of the created file using GtkHash so in future I am sure the file was not changed in any way.

1

if the message is displayed at the command nrg2iso file.nrg file.iso:

file.nrg is already an ISO 9660 image [ Aborting conversion ]

use

sudo mount -t iso9660  /mnt

worked for me

  • For this VERY specific case, it means that your ISO was renamed to NRG because the file is actually an ISO9660, which means, you would logically rename it back to ISO and proceed on using it like a normal ISO file. Now, for an NRG (Which is specific to Nero), it would not be ISO compliant. – Luis Alvarado Mar 28 '16 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.